Bug 1757134

Summary: The modify/edit view of "UpdateStrategy" Descriptor is missing
Product: OpenShift Container Platform Reporter: Samuel Padgett <spadgett>
Component: Management ConsoleAssignee: Cyril <cajieh>
Status: CLOSED ERRATA QA Contact: Yadan Pei <yapei>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 4.2.0CC: aos-bugs, cajieh, dageoffr, jokerman, spadgett, tony.wu, yanpzhan, yapei
Target Milestone: ---Keywords: Reopened
Target Release: 4.2.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1753812 Environment:
Last Closed: 2019-11-13 18:55:47 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1753812    
Bug Blocks:    

Comment 3 Yanping Zhang 2019-10-28 07:28:51 UTC
Checked on OCP 4.2 with payload: 4.2.0-0.nightly-2019-10-27-140004
Steps to verify:
1. Install Portworx Operator from OperatorHub
2. On "Installed Operators" view, add "UpdateStrategy" descriptor to Portworx's CSV file under "specDescriptor" section.
3. Create "StorageCluster" CR with "Edit Form" view
4. Select "Recreate" in "UpdateStrategy" widget/field in the creation form and "Create"
5. "Update Strategy" field on "StorageCluster" details is shown correctly.
6. Click "Recreate" under "UpdateStratedy" field, the update form is opened, and update strategy to "RollingUpdate", click "Save".
7. Update succeeds, and "RollingUpdate" is shown under "Update Strategy" field now.
The bug has been fixed, so move it to Verified.

Comment 5 errata-xmlrpc 2019-11-13 18:55:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3303