Bug 1753812 - The modify/edit view of "UpdateStrategy" Descriptor is missing
Summary: The modify/edit view of "UpdateStrategy" Descriptor is missing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.3.0
Assignee: Cyril
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1757134
TreeView+ depends on / blocked
 
Reported: 2019-09-20 00:53 UTC by tony.wu
Modified: 2020-01-23 11:07 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Consequence: Fix: Yes. Implemented an edit/update UI widget for "UpdateStrategy" field Result: The "UpdateStrategy" field have a clickable link to get back to the edit/update UI widget for update.
Clone Of:
: 1757134 (view as bug list)
Environment:
Last Closed: 2020-01-23 11:06:39 UTC
Target Upstream Version:


Attachments (Terms of Use)
Sample Portworx CSV with "UpdateStrategy" added in specDescriptor. (41.12 KB, text/plain)
2019-09-20 00:53 UTC, tony.wu
no flags Details
UpdateStrategyModal (93.47 KB, image/png)
2019-10-24 08:40 UTC, Yadan Pei
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 2864 None None None 2020-01-23 21:15:21 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:07:04 UTC

Description tony.wu 2019-09-20 00:53:28 UTC
Created attachment 1616959 [details]
Sample Portworx CSV with "UpdateStrategy" added in specDescriptor.

Portworx CSV with "UpdateStrategy" added in specDescriptor

Description of problem:
Apply "UpdateStrategy" Descriptor to Operator CSV for creating the CR it owns. 

The "UpdateStrategy" field on CR details view shows correctly but there's no way to get to the UI widget again to modify the configuration after creation on the CR details view.


Version-Release number of selected component (if applicable):

4.2.0-0.ci-2019-09-19-102724


How reproducible:
100% reproducible with Portworx Operator (with its CSV added 'UpdateStrategy' Descriptor)

Steps to Reproduce:
1. Install Portworx Operator from OperatorHub
2. On "Installed Operators" view, add "UpdateStrategy" descriptor to Portworx's CSV file under "specDescriptor" section (see attached CSV file: clusterserviceversion-portworx-operator.v1.0.5.yaml, as the example)
3. Create "StorageCluster" CR with "Edit Form" view
4. Select "Recreate" in "UpdateStrategy" widget/field in the creation form and "Create"
5. "UpdateStrategy" field on "StorageCluster" details view does set up correctly, but no way to get back to the UI widget for changing the configuration.

Actual results:
"UpdateStrategy" field on "StorageCluster" details view is rendered as text.

Expected results:
"UpdateStrategy" field should provide a way to get back to the UI widget.

Additional info:
Attached a sample Portworx CSV with "UpdateStrategy" added in specDescriptor.

Comment 1 Dan Geoffroy 2019-09-20 16:01:12 UTC
Moving this out to 4.3 as this is not considered a release blocker.

Comment 5 Yadan Pei 2019-10-24 08:39:28 UTC
1. cluster admin subscribe `Portworx Enterprise` operator from Operator Hub
2. After operator is created, go to Installed Operators -> Portworx Enterprise -> YAML tab -> update `specDescriptors` as following(Update Strategy is added) -> Save the yaml
       specDescriptors:
          - description: The docker image name and version of Portworx Enterprise.
            displayName: Image
            path: image
          - description: The update strategy of the deployment
            displayName: Update Strategy
            path: updateStrategy
            x-descriptors:
              - 'urn:alm:descriptor:com.tectonic.ui:updateStrategy'
          - description: >-
              It is the pull policy for the image. Takes one of Always, Never,
              IfNotPresent. Defaults to Always.
            displayName: Image Pull Policy
            path: imagePullPolicy
3. Go back to `StorageCluster` tab -> click `Create StorageCluster` button -> choose `Edit Form` view to create CR
4. Select "Recreate" in "UpdateStrategy" widget/field in the creation form and "Create"
5. After CR is created, goes to "StorageCluster" details view, `Update Strategy` shows Recreate correctly, click on the button it will open `Edit Update Strategy` modal, change it to `Rolling Update` and Save
6. CR Update Strategy can be successfully updated to `Rolling Update`

Verified on     4.3.0-0.nightly-2019-10-24-004924

Comment 6 Yadan Pei 2019-10-24 08:40:01 UTC
Created attachment 1628774 [details]
UpdateStrategyModal

Comment 8 errata-xmlrpc 2020-01-23 11:06:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.