Bug 1767436

Summary: Banshee cannot be installed because of conflicting requests.
Product: [Fedora] Fedora Reporter: Lukas Ruzicka <lruzicka>
Component: bansheeAssignee: Tom "spot" Callaway <tcallawa>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 31CC: chkr, claudiorodrigo, mailinglists, moez.roy, tcallawa
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-11-11 01:05:28 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Lukas Ruzicka 2019-10-31 13:22:10 UTC
Description of problem:

On Fedora 31, when I want to install banshee, DNF complains about conflicting requests. It seems that Banshee requires Mono but nothing provides it.

Version-Release number of selected component (if applicable):
banshee-2.6.2-34

How reproducible:
Always

Steps to Reproduce:
1. sudo dnf install banshee

Actual results:

Last metadata expiration check: 0:57:58 ago on Thu 31 Oct 2019 01:19:23 PM CET.
Error: 
 Problem: conflicting requests
  - nothing provides mono(Mono.Zeroconf) = 4.0.0.90 needed by banshee-2.6.2-34.fc31.x86_64
  - nothing provides mono(gudev-sharp) = 1.0.0.0 needed by banshee-2.6.2-34.fc31.x86_64
  - nothing provides mono(notify-sharp) = 0.4.0.0 needed by banshee-2.6.2-34.fc31.x86_64
(try to add '--skip-broken' to skip uninstallable packages)

Expected results:

Banshee can be installed.

Comment 1 Tom "spot" Callaway 2019-10-31 13:27:23 UTC
Looks like some mono packages didn't get rebuilt after the auto-generated mono provides tooling was put back in place. Should be easy enough to fix.

Comment 2 Lukas Ruzicka 2019-10-31 13:34:13 UTC
Thanks for looking into it. :)

Comment 3 Fedora Update System 2019-10-31 13:39:48 UTC
FEDORA-2019-bf9384ecd1 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-bf9384ecd1

Comment 4 Lukas Ruzicka 2019-11-01 08:49:54 UTC
This update works as expected. Thank you very much for your work. I am setting to verified.

Comment 5 Fedora Update System 2019-11-03 06:00:57 UTC
gudev-sharp-0.1-27.fc31, mono-zeroconf-0.9.0-27.fc31, notify-sharp-0.4.1-0.8.20130131git28d2f65.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-bf9384ecd1

Comment 6 Fedora Update System 2019-11-11 01:05:28 UTC
gudev-sharp-0.1-27.fc31, mono-zeroconf-0.9.0-27.fc31, notify-sharp-0.4.1-0.8.20130131git28d2f65.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.