Bug 1767436 - Banshee cannot be installed because of conflicting requests.
Summary: Banshee cannot be installed because of conflicting requests.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: banshee
Version: 31
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-31 13:22 UTC by Lukas Ruzicka
Modified: 2019-11-11 01:05 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-11 01:05:28 UTC


Attachments (Terms of Use)

Description Lukas Ruzicka 2019-10-31 13:22:10 UTC
Description of problem:

On Fedora 31, when I want to install banshee, DNF complains about conflicting requests. It seems that Banshee requires Mono but nothing provides it.

Version-Release number of selected component (if applicable):
banshee-2.6.2-34

How reproducible:
Always

Steps to Reproduce:
1. sudo dnf install banshee

Actual results:

Last metadata expiration check: 0:57:58 ago on Thu 31 Oct 2019 01:19:23 PM CET.
Error: 
 Problem: conflicting requests
  - nothing provides mono(Mono.Zeroconf) = 4.0.0.90 needed by banshee-2.6.2-34.fc31.x86_64
  - nothing provides mono(gudev-sharp) = 1.0.0.0 needed by banshee-2.6.2-34.fc31.x86_64
  - nothing provides mono(notify-sharp) = 0.4.0.0 needed by banshee-2.6.2-34.fc31.x86_64
(try to add '--skip-broken' to skip uninstallable packages)

Expected results:

Banshee can be installed.

Comment 1 Tom "spot" Callaway 2019-10-31 13:27:23 UTC
Looks like some mono packages didn't get rebuilt after the auto-generated mono provides tooling was put back in place. Should be easy enough to fix.

Comment 2 Lukas Ruzicka 2019-10-31 13:34:13 UTC
Thanks for looking into it. :)

Comment 3 Fedora Update System 2019-10-31 13:39:48 UTC
FEDORA-2019-bf9384ecd1 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-bf9384ecd1

Comment 4 Lukas Ruzicka 2019-11-01 08:49:54 UTC
This update works as expected. Thank you very much for your work. I am setting to verified.

Comment 5 Fedora Update System 2019-11-03 06:00:57 UTC
gudev-sharp-0.1-27.fc31, mono-zeroconf-0.9.0-27.fc31, notify-sharp-0.4.1-0.8.20130131git28d2f65.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-bf9384ecd1

Comment 6 Fedora Update System 2019-11-11 01:05:28 UTC
gudev-sharp-0.1-27.fc31, mono-zeroconf-0.9.0-27.fc31, notify-sharp-0.4.1-0.8.20130131git28d2f65.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.