Bug 1767840

Summary: ceph RadosGW should use the role "member" instead of "Member"
Product: Red Hat OpenStack Reporter: Giulio Fidente <gfidente>
Component: openstack-tripleo-heat-templatesAssignee: Giulio Fidente <gfidente>
Status: CLOSED ERRATA QA Contact: Yogev Rabl <yrabl>
Severity: high Docs Contact:
Priority: high    
Version: 15.0 (Stein)CC: amcleod, elicohen, gfidente, mburns, nweinber, ssmolyak, yrabl
Target Milestone: z2Keywords: Triaged, ZStream
Target Release: 15.0 (Stein)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-tripleo-heat-templates-10.6.2-0.20191113030444.fc5ca30.el8ost.noarch.rpm Doc Type: Bug Fix
Doc Text:
Previously, changing the default membership role from `Member` to `member` caused ceph-rgw to deny access to standard users because keystone roles are case insensitive, but ceph-rgw role matching is case sensitive. As a result, users with the `member` role could not access ceph-rgw. With this update, ceph-rgw accepts users with both `Member` and `member` roles.
Story Points: ---
Clone Of: 1767593 Environment:
Last Closed: 2020-03-05 12:00:28 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Comment 6 Yogev Rabl 2019-12-18 17:34:00 UTC
Verified

Comment 7 Alex McLeod 2020-02-19 12:44:23 UTC
If this bug requires doc text for errata release, please set the 'Doc Type' and provide draft text according to the template in the 'Doc Text' field. The documentation team will review, edit, and approve the text.

If this bug does not require doc text, please set the 'requires_doc_text' flag to '-'.

Comment 9 errata-xmlrpc 2020-03-05 12:00:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0643