Bug 1781211

Summary: OVN octavia driver fails to load
Product: Red Hat OpenStack Reporter: Maciej Józefczyk <mjozefcz>
Component: python-networking-ovnAssignee: Maciej Józefczyk <mjozefcz>
Status: CLOSED ERRATA QA Contact: Eran Kuris <ekuris>
Severity: high Docs Contact:
Priority: medium    
Version: 15.0 (Stein)CC: apevec, lhh, majopela, scohen
Target Milestone: ---Keywords: Triaged, ZStream
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: python-networking-ovn-6.0.1-0.20191209190441.d143285.el8ost Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-03-05 11:53:50 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Maciej Józefczyk 2019-12-09 14:43:35 UTC
Description of problem:

OVN octavia driver fails to load during agent initialization on stable/stein OSP15.

How reproducible:
Enable OVN octavia provider driver with stable/stein version, try to start Octavia service:

Dec 09 08:34:02 mjozefcz-stein-lb devstack@o-api.service[16043]: ERROR octavia.api.drivers.driver_factory [-] Unable to load provider driver ovn due to: duplicate option: host: DuplicateOptError: duplicate option: host
Dec 09 08:34:02 mjozefcz-stein-lb devstack@o-api.service[16043]: CRITICAL octavia [-] Unhandled error: ProviderNotFound: Provider 'ovn' was not found.

Comment 6 errata-xmlrpc 2020-03-05 11:53:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0709