Bug 1781211 - OVN octavia driver fails to load
Summary: OVN octavia driver fails to load
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-networking-ovn
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: ---
Assignee: Maciej Józefczyk
QA Contact: Eran Kuris
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-09 14:43 UTC by Maciej Józefczyk
Modified: 2020-03-05 11:54 UTC (History)
4 users (show)

Fixed In Version: python-networking-ovn-6.0.1-0.20191209190441.d143285.el8ost
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-05 11:53:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1855672 0 None None None 2019-12-09 14:44:33 UTC
OpenStack gerrit 697993 0 'None' MERGED Do not import networking_ovn.ovsdb.worker in impl_idl_ovn 2020-08-12 09:19:14 UTC
Red Hat Product Errata RHBA-2020:0709 0 None None None 2020-03-05 11:54:15 UTC

Description Maciej Józefczyk 2019-12-09 14:43:35 UTC
Description of problem:

OVN octavia driver fails to load during agent initialization on stable/stein OSP15.

How reproducible:
Enable OVN octavia provider driver with stable/stein version, try to start Octavia service:

Dec 09 08:34:02 mjozefcz-stein-lb devstack@o-api.service[16043]: ERROR octavia.api.drivers.driver_factory [-] Unable to load provider driver ovn due to: duplicate option: host: DuplicateOptError: duplicate option: host
Dec 09 08:34:02 mjozefcz-stein-lb devstack@o-api.service[16043]: CRITICAL octavia [-] Unhandled error: ProviderNotFound: Provider 'ovn' was not found.

Comment 6 errata-xmlrpc 2020-03-05 11:53:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0709


Note You need to log in before you can comment on or make changes to this bug.