Bug 1783953

Summary: [virtio-win-prewhql-174] rng,serial and input driver install failed on Win7 and Win2008r2 guest.
Product: Red Hat Enterprise Linux 8 Reporter: menli <menli>
Component: virtio-winAssignee: ybendito
virtio-win sub component: virtio-win-prewhql QA Contact: menli <menli>
Status: CLOSED ERRATA Docs Contact:
Severity: high    
Priority: high CC: ailan, lijin, lmiksik, vrozenfe, xiagao, ybendito, yvugenfi
Version: 8.1Keywords: Regression
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: virtio-win-prewhql-0.1-175 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-04-28 16:05:16 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
error info
none
setupapi.dev.log none

Description menli@redhat.com 2019-12-16 10:24:47 UTC
Created attachment 1645543 [details]
error info

Description of problem:
174 virtio rng ,serial,input driver can not be installed successfully on Win7.

Version-Release number of selected component (if applicable):
kernel-4.18.0-147.0.3.el8_1.x86_64
qemu-kvm-4.1.0-19.module+el8.1.1+5172+e3ff58a1.x86_64
virtio-win-prewhql-174

How reproducible:
100%

Steps to Reproduce:
1.Boot up win7 guest with rng,serial and input device

-object rng-random,filename=/dev/urandom,id=rng0  -device virtio-rng-pci,id=rng1,rng=rng0,bus=pci.4,addr=0x0  \
-device virtio-serial-pci,id=virtio-serial1,max_ports=31,bus=pci.5 \
-chardev socket,id=channel2,path=/tmp/helloworld2,server,nowait  -device virtserialport,bus=virtio-serial1.0,chardev=channel2,name=org.qemu.guest_agent.0,id=port2 \
-device virtio-keyboard-pci,id=kbd0,serial=virtio-keyboard,bus=pci.6 -device virtio-mouse-pci,id=mouse0,serial=virtio-mouse  -device virtio-tablet-pci,id=tablet0,serial=virtio-tablet

2.Install rng,serial and input driver with 174 version


Actual results:
Driver can not be installed successfully.

Expected results:
driver works well

Additional info:
1. Not hit this issue with 173 version
2. Error info is in attachment

Comment 2 menli@redhat.com 2019-12-17 05:10:26 UTC
Created attachment 1645739 [details]
setupapi.dev.log

uploaded setupapi.dev.log in attachment.

Comment 5 ybendito 2019-12-19 07:30:05 UTC
Fixed in virtio-win-prewhql-0.1-175

Comment 6 menli@redhat.com 2019-12-19 10:42:33 UTC
Verify this bug with virtio-win-prewhql-0.1-175.
rng,input and serial drivers work.

Comment 12 errata-xmlrpc 2020-04-28 16:05:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2020:1757

Comment 13 ybendito 2020-05-01 03:14:29 UTC
In my opinion, no special documentation required as the build with the bug was never released.
The problem exists only in intermediate build