Bug 1783953 - [virtio-win-prewhql-174] rng,serial and input driver install failed on Win7 and Win2008r2 guest.
Summary: [virtio-win-prewhql-174] rng,serial and input driver install failed on Win7 a...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: virtio-win
Version: 8.1
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: ybendito
QA Contact: menli@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-16 10:24 UTC by menli@redhat.com
Modified: 2020-05-01 03:14 UTC (History)
7 users (show)

Fixed In Version: virtio-win-prewhql-0.1-175
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 16:05:16 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
error info (61.52 KB, image/png)
2019-12-16 10:24 UTC, menli@redhat.com
no flags Details
setupapi.dev.log (1.28 MB, text/plain)
2019-12-17 05:10 UTC, menli@redhat.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2020:1757 None None None 2020-04-28 16:05:30 UTC

Description menli@redhat.com 2019-12-16 10:24:47 UTC
Created attachment 1645543 [details]
error info

Description of problem:
174 virtio rng ,serial,input driver can not be installed successfully on Win7.

Version-Release number of selected component (if applicable):
kernel-4.18.0-147.0.3.el8_1.x86_64
qemu-kvm-4.1.0-19.module+el8.1.1+5172+e3ff58a1.x86_64
virtio-win-prewhql-174

How reproducible:
100%

Steps to Reproduce:
1.Boot up win7 guest with rng,serial and input device

-object rng-random,filename=/dev/urandom,id=rng0  -device virtio-rng-pci,id=rng1,rng=rng0,bus=pci.4,addr=0x0  \
-device virtio-serial-pci,id=virtio-serial1,max_ports=31,bus=pci.5 \
-chardev socket,id=channel2,path=/tmp/helloworld2,server,nowait  -device virtserialport,bus=virtio-serial1.0,chardev=channel2,name=org.qemu.guest_agent.0,id=port2 \
-device virtio-keyboard-pci,id=kbd0,serial=virtio-keyboard,bus=pci.6 -device virtio-mouse-pci,id=mouse0,serial=virtio-mouse  -device virtio-tablet-pci,id=tablet0,serial=virtio-tablet

2.Install rng,serial and input driver with 174 version


Actual results:
Driver can not be installed successfully.

Expected results:
driver works well

Additional info:
1. Not hit this issue with 173 version
2. Error info is in attachment

Comment 2 menli@redhat.com 2019-12-17 05:10:26 UTC
Created attachment 1645739 [details]
setupapi.dev.log

uploaded setupapi.dev.log in attachment.

Comment 5 ybendito 2019-12-19 07:30:05 UTC
Fixed in virtio-win-prewhql-0.1-175

Comment 6 menli@redhat.com 2019-12-19 10:42:33 UTC
Verify this bug with virtio-win-prewhql-0.1-175.
rng,input and serial drivers work.

Comment 12 errata-xmlrpc 2020-04-28 16:05:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2020:1757

Comment 13 ybendito 2020-05-01 03:14:29 UTC
In my opinion, no special documentation required as the build with the bug was never released.
The problem exists only in intermediate build


Note You need to log in before you can comment on or make changes to this bug.