Bug 178728

Summary: when usb raid on usb or firewire raidautorun fails
Product: Red Hat Enterprise Linux 4 Reporter: Sal Scotto <sal.scotto>
Component: initscriptsAssignee: Bill Nottingham <notting>
Status: CLOSED DUPLICATE QA Contact: Brock Organ <borgan>
Severity: medium Docs Contact:
Priority: medium    
Version: 4.0CC: rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-08-01 12:36:31 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Sal Scotto 2006-01-23 15:13:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041215 Firefox/1.0 Red Hat/1.0-12.EL4

Description of problem:
I built a usb raid5 device set under md0 which has LVM on top of it, and is NOT the root fielsystem.
md0 is composed of 5 USB drives sd[a-e]

On line 220 on rc.sysinit
echo "raidautorun /dev/md0" | nash --quiet

will fail as it tries to mount /dev/md0 it fails because the usb subsystem has not yet fully created all the udev nodes for the usb devices. This will cause a boot panic and dump you into single user mode.

Version-Release number of selected component (if applicable):
initscripts-7.93.11.EL-1

How reproducible:
Always

Steps to Reproduce:
1. you need 3 external usb hardrives
2. create 3 usb external HD parted as software raid and define md0 to be sd[a-c]
3. reboot

  

Additional info:
Comment 1 Bill Nottingham 2006-01-23 18:03:20 EST
echo "raidautorun /dev/md0" | nash --quiet

This does not try to mount the device... that does not happen until later.

Can you get the kernel messages when it drops you to single-user mode? Is it
creating an incomplete array?
Comment 2 Sal Scotto 2006-01-24 09:17:04 EST
when the autorun executes it does try to start md0, sicne the devices arent all
present, the raid fails to start resulting in a failed array with 0 devices
single since udev hasnt added the node for the usb devices yet.
Comment 3 Bill Nottingham 2006-01-24 09:33:49 EST
OK. mdadm -As later does not reassemble it once it fails, correct?
Comment 4 Sal Scotto 2006-01-24 11:22:05 EST
mdadm -As will assemble it later on, IF you stop the raidautorun from invoking
so you can finish the boot process without dropping into single user mode.
Comment 5 Bill Nottingham 2006-01-24 11:51:13 EST
The drop into single user mode should be after mdadm runs.... it shouldn't get
fscked until the second invocation.
Comment 6 Sal Scotto 2006-01-24 14:11:50 EST
correct, but when it tries to assemble not all the drives are ready , marks
drives as bad, you can force a clean re-assmbly later but once you exit single
user as you know it reboots, doing it all over again
Comment 7 Bill Nottingham 2006-08-01 12:36:31 EDT

*** This bug has been marked as a duplicate of 198704 ***