Bug 198704 - LVM2 init may fail if dm_mod is still checking disks
LVM2 init may fail if dm_mod is still checking disks
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: udev (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
: 178728 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-12 19:18 EDT by Gordon Messmer
Modified: 2014-11-10 07:34 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 16:28:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ls -lR /dev, during LVM2 init in rc.sysinit (10.93 KB, text/plain)
2006-07-13 14:12 EDT, Gordon Messmer
no flags Details
ls -lR /dev, during LVM2 init in rc.sysinit, after sleeping (13.65 KB, text/plain)
2006-07-13 14:12 EDT, Gordon Messmer
no flags Details
strace of vgscan, during LVM2 init in rc.sysinit (11.05 KB, application/octet-stream)
2006-07-13 14:14 EDT, Gordon Messmer
no flags Details
strace of vgscan, during LVM2 init in rc.sysinit, after sleeping (11.88 KB, application/octet-stream)
2006-07-13 14:14 EDT, Gordon Messmer
no flags Details

  None (edit)
Description Gordon Messmer 2006-07-12 19:18:42 EDT
Description of problem:
Some of the time, the LVM2 init section of rc.sysinit will be ineffective. 
Specifically, vgscan will not find any volume groups.  I believe that the system
started up normally once, but since has not done so without modifications to the
rc.sysinit file.

I've determined that if I add a 'sleep' to rc.sysinit, immediately before
calling vgscan, vgscan will locate the volume groups.  I'm using 30 seconds now,
but don't know what minimum is required.

I'm guessing that the device mapper hadn't found the volume on sdb yet, but I'm
not sure how I'd prove it without more knowledge of the way that those kernel
components function.

Version-Release number of selected component (if applicable):
initscripts-7.93.24.EL-1.1

How reproducible:
Unsure, but it seems consistent and reproducible here.

Steps to Reproduce:
1. Create LVM device (ours is a 4.55TB volume with just one PV: /dev/sdb)
2. Reboot
3. Log in and check "vgdisplay", you'll see no volumes have been found.
  
Actual results:
vgscan didn't find the volume we'd created, when run during rc.sysinit, unless
there was a brief pause after loading the dm_mod module.

Expected results:
vgscan should find the volume, and vgchange should activate it.

Additional info:
sdb is a RAID5 volume on a 3ware 9550SX card.  We used LVM because we plan to
put a second card and set of disks in the system at some point, and will want to
include those disks in the same filesystem.
Comment 1 Bill Nottingham 2006-07-12 20:13:06 EDT
Hm, can you get a strace of it failing?
Comment 2 Gordon Messmer 2006-07-13 14:11:13 EDT
Yeah, sure.  I traced the process before and after the sleep, and saw that "sdb"
didn't exist in /dev on the first run.  Afterward, I also got the output of 'ls
-lR /dev' before and after the 'sleep'.
Comment 3 Gordon Messmer 2006-07-13 14:12:19 EDT
Created attachment 132391 [details]
ls -lR /dev, during LVM2 init in rc.sysinit
Comment 4 Gordon Messmer 2006-07-13 14:12:45 EDT
Created attachment 132392 [details]
ls -lR /dev, during LVM2 init in rc.sysinit, after sleeping
Comment 5 Gordon Messmer 2006-07-13 14:14:24 EDT
Created attachment 132393 [details]
strace of vgscan, during LVM2 init in rc.sysinit
Comment 6 Gordon Messmer 2006-07-13 14:14:47 EDT
Created attachment 132394 [details]
strace of vgscan, during LVM2 init in rc.sysinit, after sleeping
Comment 7 Bill Nottingham 2006-08-01 11:51:21 EDT
How hard would it be to add something like udevsettle to RHEL 4's udev?
Comment 8 Bill Nottingham 2006-08-01 12:36:55 EDT
*** Bug 178728 has been marked as a duplicate of this bug. ***
Comment 9 Harald Hoyer 2006-08-01 12:51:17 EDT
would be possible, not sooo hard.
Comment 10 Harald Hoyer 2007-03-08 08:33:11 EST
is this still a problem?
Comment 11 Gordon Messmer 2007-03-14 13:54:31 EDT
I may be able to check next week, when summer vacation begins.  The only system
where we see this problem is a file server for our students.  I don't have a
test system on which to reproduce the problem outside of the production environment.
Comment 12 Gordon Messmer 2007-03-19 17:02:53 EDT
We updated the system today, and it seems to be fixed.  If the problem comes
back, I'll reopen this bug.
Comment 13 Jack Neely 2007-08-10 18:02:22 EDT
I just encountered this bug on a RHEL 4.4 fully updated system.  (Which means
RHEL 4.5)  I inserted a "sleep 20" around line 512.  After the sleep the device
/dev/sdb exists and the vgchange command activates its logical volumes.

sdb is a 10T JetStor 516F connected via 4Gb FC to a QLogic QLE2460 HBA and the
hardware platform is a Dell 2950.
Comment 15 RHEL Product and Program Management 2008-09-05 13:12:08 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 20 errata-xmlrpc 2009-05-18 16:28:56 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1004.html

Note You need to log in before you can comment on or make changes to this bug.