Bug 1788161

Summary: Authentication operator is degraded in IPv6 cluster
Product: OpenShift Container Platform Reporter: chris alfonso <calfonso>
Component: NetworkingAssignee: Dan Mace <dmace>
Networking sub component: router QA Contact: Hongan Li <hongli>
Status: CLOSED DUPLICATE Docs Contact:
Severity: urgent    
Priority: unspecified CC: aos-bugs, calfonso, dmace, hongli, mfojtik, pkrupa, scuppett
Version: 4.3.z   
Target Milestone: ---   
Target Release: 4.3.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1788135 Environment:
Last Closed: 2020-01-07 13:26:14 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 1788135, 1788526    
Bug Blocks:    

Description chris alfonso 2020-01-06 15:09:39 UTC
+++ This bug was initially created as a clone of Bug #1788135 +++

Description of problem:
Authentication operator is degraded causing oauth-proxies to fail

Version-Release number of selected component (if applicable):
4.3.0-0.nightly-2019-12-18-145749-ipv6.1

How reproducible:
Always

Steps to Reproduce:
1. Start an IPv6 cluster


Actual results:
Installation fails with following message:

```
DEBUG Still waiting for the cluster to initialize: Some cluster operators are still updating: authentication, console 
DEBUG Still waiting for the cluster to initialize: Some cluster operators are still updating: authentication, console 
DEBUG Still waiting for the cluster to initialize: Working towards 4.3.0-0.nightly-2019-12-18-145749-ipv6.1: 100% complete 
DEBUG Still waiting for the cluster to initialize: Some cluster operators are still updating: authentication, console 
ERROR Cluster operator authentication Degraded is True with RouteHealthDegradedFailedGet: RouteHealthDegraded: failed to GET route: net/http: TLS handshake timeout 
INFO Cluster operator authentication Progressing is Unknown with NoData:  
INFO Cluster operator authentication Available is Unknown with NoData:  
INFO Cluster operator console Progressing is True with SyncLoopRefreshProgressingInProgress: SyncLoopRefreshProgressing: Working toward version 4.3.0-0.nightly-2019-12-18-145749-ipv6.1 
INFO Cluster operator console Available is False with DeploymentAvailableInsufficientReplicas: DeploymentAvailable: 0 pods available for console deployment 
INFO Cluster operator insights Disabled is False with :  
FATAL failed to initialize the cluster: Some cluster operators are still updating: authentication, console
```


Expected results:
Installation succeeds and operator is not degraded


Additional info:

Comment 1 Stephen Cuppett 2020-01-07 13:26:14 UTC

*** This bug has been marked as a duplicate of bug 1788526 ***