Bug 1788526 - Authentication operator is degraded in IPv6 cluster
Summary: Authentication operator is degraded in IPv6 cluster
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: apiserver-auth
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 4.3.z
Assignee: Stefan Schimanski
QA Contact: Marius Cornea
URL:
Whiteboard:
: 1788161 (view as bug list)
Depends On: 1788135 1796618
Blocks: 1788161
TreeView+ depends on / blocked
 
Reported: 2020-01-07 12:26 UTC by Michal Fojtik
Modified: 2020-02-25 06:18 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1788135
Environment:
Last Closed: 2020-02-25 06:17:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-authentication-operator pull 233 None closed Bug 1788526: Fix IPv6 Support [release-4.3] 2020-04-01 05:12:21 UTC
Red Hat Product Errata RHBA-2020:0528 None None None 2020-02-25 06:18:12 UTC

Comment 1 Stephen Cuppett 2020-01-07 13:26:14 UTC
*** Bug 1788161 has been marked as a duplicate of this bug. ***

Comment 3 Hongan Li 2020-01-08 02:29:16 UTC
Hi Dan, seems the fix PR is for authentication operator instead of ingress. Do you think should update component to Auth?

Comment 5 Dan Winship 2020-02-07 14:25:20 UTC
Assigning all 4.3.z IPv6 bugs to Marius Cornea for QA, as they are not yet QA-able in stock release-4.3 builds.

Comment 6 Marius Cornea 2020-02-11 21:40:14 UTC
Verified on 4.3.0-0.nightly-2020-02-10-055634(included in 4.3.0-0.nightly-2020-02-10-055634-ipv6.3) on a bare metal deployment

Image used in local disconnected registry:
[kni@provisionhost-0 ~]$ oc adm release info --image-for=cluster-authentication-operator  -a ~/combined-secret.json   registry.ocp-edge-cluster.qe.lab.redhat.com:5000/localimages/local-release-image:4.3.0-0.nightly-2020-02-10-055634-ipv6.3
quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:f6c4d9cab2c9f099a466795d902b8f508391087d025b51dfd742e41b6e7e1249


Image used in 4.3.0-0.nightly-2020-02-10-055634
[kni@provisionhost-0 ~]$ 
[kni@provisionhost-0 ~]$ oc adm release info --image-for=cluster-authentication-operator  -a ~/combined-secret.json   registry.svc.ci.openshift.org/ocp/release:4.3.0-0.nightly-2020-02-10-055634
quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:f6c4d9cab2c9f099a466795d902b8f508391087d025b51dfd742e41b6e7e1249


[kni@provisionhost-0 ~]$ oc get co/authentication 
NAME             VERSION                                    AVAILABLE   PROGRESSING   DEGRADED   SINCE
authentication   4.3.0-0.nightly-2020-02-10-055634-ipv6.3   True        False         False      77m

Comment 8 errata-xmlrpc 2020-02-25 06:17:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0528


Note You need to log in before you can comment on or make changes to this bug.