Bug 1789084

Summary: node_exporter does not report virt_platform{type="none"}
Product: OpenShift Container Platform Reporter: Clayton Coleman <ccoleman>
Component: MonitoringAssignee: Paul Gier <pgier>
Status: CLOSED ERRATA QA Contact: Junqi Zhao <juzhao>
Severity: high Docs Contact:
Priority: unspecified    
Version: 4.3.zCC: alegrand, anpicker, erooth, juzhao, kakkoyun, lcosic, mloibl, pkrupa, surbania
Target Milestone: ---   
Target Release: 4.3.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1789083
: 1789085 (view as bug list) Environment:
Last Closed: 2020-03-10 23:52:55 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1789083    
Bug Blocks: 1789085    

Description Clayton Coleman 2020-01-08 17:19:17 UTC
+++ This bug was initially created as a clone of Bug #1789083 +++

When we fixed the last bug in the virt_platform node_exporter metric, we accidentally broke the type="none" calculation.  We need to fix this and back port to 4.2.

Comment 5 Junqi Zhao 2020-02-24 10:13:25 UTC
tested with the fix on 4.3.0-0.nightly-2020-02-23-174848, we can find virt_platform{type="none"} in /var/node_exporter/textfile/virt.prom file of node-exporter pods

# HELP virt_platform reports one series per detected virtualization type. If no type is detected, the type is "none".
# TYPE virt_platform gauge
virt_platform{type="none"} 1

Comment 7 errata-xmlrpc 2020-03-10 23:52:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0676