Bug 1791907

Summary: [4.3] Pipeline default param breaks PipelineRuns
Product: OpenShift Container Platform Reporter: Andrew Ballantyne <aballant>
Component: Dev ConsoleAssignee: Andrew Ballantyne <aballant>
Status: CLOSED ERRATA QA Contact: Gajanan More <gamore>
Severity: urgent Docs Contact:
Priority: urgent    
Version: 4.2.zCC: aos-bugs, nmukherj, rgarg, scuppett, spathak
Target Milestone: ---Keywords: Reopened
Target Release: 4.3.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1790557 Environment:
Last Closed: 2020-02-12 09:42:20 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1790557    

Description Andrew Ballantyne 2020-01-16 16:52:40 UTC
+++ This bug was initially created as a clone of Bug #1790557 +++

Description of problem: 
When using the `default` property in a Pipeline param, it prevents the UI from creating a PipelineRun due to it straight copying the params and `default` is not a valid property in a PipelineRun params.


Version-Release number of selected component (if applicable):
4.2.14 of OpenShift Console


How reproducible:
100% when Pipeline params has a `default` property. Otherwise not an issue.


Steps to Reproduce:
1. Create a Pipeline with a param that includes a `default` property
2. Try to start the Pipeline

Actual results:
There is no UI update / error. The UI does nothing when the Pipeline is trying to be started. The PipelineRun is not created.

Expected results:
The PipelineRun to be created and thus starting the Pipeline. Shouldn't have an issue with `default` in Pipeline params.

Additional info:

--- Additional comment from Andrew Ballantyne on 2020-01-13 15:49:49 UTC ---

Jira issue: https://issues.redhat.com/browse/ODC-2719

--- Additional comment from Andrew Ballantyne on 2020-01-16 16:46:20 UTC ---

Became a blocker from PM's point of view when we investigated and found that even without a `default` the params provided a `default` with the value the user enters in the UI... thus causing the issue 100% anytime using Pipeline params.

Comment 1 Andrew Ballantyne 2020-01-16 16:54:58 UTC
No issue exists on 4.3, but this ticket is needed to validate that it works before it can be back-ported to 4.2

Comment 2 Andrew Ballantyne 2020-01-17 02:13:02 UTC
This is not a real issue - we fixed this already but we use Jira for bug tracking. This ticket is purely paperwork for https://bugzilla.redhat.com/show_bug.cgi?id=1790557

I need this reviewed by QE in India tomorrow morning in order to get my blocker for 4.2.z in... I'll mark this as 4.3.z in the hopes that will work for the bot in OpenShift and not get in the way of the RC for 4.3.0

PR in question: https://github.com/openshift/console/pull/3983

Comment 4 errata-xmlrpc 2020-02-12 09:42:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0391