Bug 1790557 - Pipeline default param breaks PipelineRuns
Summary: Pipeline default param breaks PipelineRuns
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.2.z
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.2.z
Assignee: Andrew Ballantyne
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On: 1791907
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-13 15:46 UTC by Andrew Ballantyne
Modified: 2020-02-24 16:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1791907 (view as bug list)
Environment:
Last Closed: 2020-02-24 16:52:45 UTC
Target Upstream Version:


Attachments (Terms of Use)
Showing the parameters without any error (100.37 KB, image/png)
2020-02-12 08:00 UTC, Gajanan More
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 3983 0 None closed Bug 1790557: Fix Pipeline Params 2020-03-02 11:07:21 UTC
Red Hat Product Errata RHBA-2020:0460 0 None None None 2020-02-24 16:52:59 UTC

Description Andrew Ballantyne 2020-01-13 15:46:00 UTC
Description of problem: 
When using the `default` property in a Pipeline param, it prevents the UI from creating a PipelineRun due to it straight copying the params and `default` is not a valid property in a PipelineRun params.


Version-Release number of selected component (if applicable):
4.2.14 of OpenShift Console


How reproducible:
100% when Pipeline params has a `default` property. Otherwise not an issue.


Steps to Reproduce:
1. Create a Pipeline with a param that includes a `default` property
2. Try to start the Pipeline

Actual results:
There is no UI update / error. The UI does nothing when the Pipeline is trying to be started. The PipelineRun is not created.

Expected results:
The PipelineRun to be created and thus starting the Pipeline. Shouldn't have an issue with `default` in Pipeline params.

Additional info:

Comment 1 Andrew Ballantyne 2020-01-13 15:49:49 UTC
Jira issue: https://issues.redhat.com/browse/ODC-2719

Comment 2 Andrew Ballantyne 2020-01-16 16:46:20 UTC
Became a blocker from PM's point of view when we investigated and found that even without a `default` the params provided a `default` with the value the user enters in the UI... thus causing the issue 100% anytime using Pipeline params.

Comment 4 Gajanan More 2020-02-12 08:00:12 UTC
Created attachment 1662610 [details]
Showing the parameters without any error

Comment 5 Gajanan More 2020-02-12 08:02:13 UTC
I have validated the bug on 
Build:4.3.1 (This is the RC build)
Browser: Google Chrome Version 78.0.3904.108 (Official Build) (64-bit)

Please find the attachment where you can see the output when user provides multiple parameters.

Comment 7 errata-xmlrpc 2020-02-24 16:52:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0460


Note You need to log in before you can comment on or make changes to this bug.