Bug 1810562

Summary: [4.4] image-registry should be running in a 2 pod configuration always
Product: OpenShift Container Platform Reporter: Oleg Bulatov <obulatov>
Component: Image RegistryAssignee: Oleg Bulatov <obulatov>
Status: CLOSED ERRATA QA Contact: Wenjing Zheng <wzheng>
Severity: high Docs Contact:
Priority: unspecified    
Version: 4.4CC: aos-bugs, ccoleman, wzheng, xiuwang
Target Milestone: ---   
Target Release: 4.4.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Feature: high available configuration by default Reason: problems with one of the registry pods should not affect availability of the registry Result: the registry has 2 replicas by default when its possible
Story Points: ---
Clone Of: 1810317
: 1810563 (view as bug list) Environment:
Last Closed: 2020-05-04 11:44:56 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1810317    
Bug Blocks: 1810563    

Description Oleg Bulatov 2020-03-05 14:01:00 UTC
+++ This bug was initially created as a clone of Bug #1810317 +++

On a 4.4 cluster there is only a single image registry pod running by default.  All of our components must run in an HA configuration by default (2 pods with normal spreading).

This must be backported to 4.3.

--- Additional comment from Clayton Coleman on 2020-03-05 00:25:16 CET ---

Note I'm fine if it's only 2 when the default backend is object storage (clouds)

Comment 2 Oleg Bulatov 2020-04-03 11:14:04 UTC
*** Bug 1811848 has been marked as a duplicate of this bug. ***

Comment 7 XiuJuan Wang 2020-04-16 02:21:54 UTC
Verified with 4.4.0-0.nightly-2020-04-15-071550 payload.
image-registry has 2 running pods, and no regression issue.

Comment 9 errata-xmlrpc 2020-05-04 11:44:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581