Bug 1817122

Summary: 'getent group ldapgroupname' doesn't show any LDAP users or some LDAP users when 'rfc2307bis' schema is used with SSSD.
Product: Red Hat Enterprise Linux 8 Reporter: Akshay Sakure <asakure>
Component: sssdAssignee: Iker Pedrosa <ipedrosa>
Status: CLOSED ERRATA QA Contact: Anuj Borah <aborah>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.1CC: atikhono, dlavu, grajaiya, ipedrosa, jhrozek, lslebodn, mzidek, pbrezina, sbose, thalman, tscherf
Target Milestone: rcKeywords: Triaged
Target Release: 8.0   
Hardware: x86_64   
OS: Linux   
Whiteboard: sync-to-jira
Fixed In Version: sssd-2.4.0-1.el8 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-05-18 15:03:54 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1881992    
Bug Blocks:    

Description Akshay Sakure 2020-03-25 15:49:29 UTC
Description of problem:
'getent group ldapgroupname' doesn't any LDAP users or some LDAP users when 'rfc2307bis' schema is used with SSSD. It shows if group is empty without any members. 

Version-Release number of selected component (if applicable):
sssd-2.2.0-19.el8.x86_64.rpm      - RHEL 8
sssd-1.16.4-21.el7_7.1.x86_64.rpm - RHEL 7


How reproducible:
Always


Steps to Reproduce:
1. Configure SSSD with id_provider = ldap and set ldap_schema = rfc2307bis
2. Check 'id ldapusername' output.
3. Check 'getent group ldapgroupname' output.


Actual results:
'getent group ldapgroupname' doesn't any LDAP users or some LDAP users.
It shows if group is empty without any members. 


Expected results:
'getent group ldapgroupname' should show ALL it's member ldapusers. 


Additional info:
This issue is observed on RHEL 7/8 with SSSD. 
This issue is not observed with RHEL 5/6 with nslcd.

Comment 16 Iker Pedrosa 2020-06-22 12:41:31 UTC
The problem happens because ldap_group_nesting_level is not set and it takes the default value, which is 2, and this seems not to be enough. I'd recommend you to play with this value to obtain the whole view of group members. You can read some information about ldap_group_nesting_level in sssd-ldap man page.

Comment 28 Iker Pedrosa 2020-09-08 11:07:10 UTC
Upstream ticket:
https://github.com/SSSD/sssd/issues/5311

Comment 33 Iker Pedrosa 2020-10-02 10:38:48 UTC
* `master`
  * https://github.com/SSSD/sssd/commit/88631392e9172ae4fa3e411398516a2f39f0060e - intg: allow member DN to have a different case
  * https://github.com/SSSD/sssd/commit/50d0d154cedb6915ab321b47c40851c40e91cf41 - ldap: use member DN to create ghost user hash table

Comment 49 errata-xmlrpc 2021-05-18 15:03:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (sssd bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:1666