Bug 181775

Summary: spec file correction so that rpmbuild works as expected on RHEL systems
Product: [Fedora] Fedora Reporter: Saurabh Bathe <sbathe>
Component: blacsAssignee: Tom "spot" Callaway <tcallawa>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 3CC: extras-qa
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-04-07 18:32:05 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Saurabh Bathe 2006-02-16 14:37:06 UTC
Description of problem: The buildrequires for lam in spec file seems to be
incorrect. The build should fail for RHEL3/4 but it does not.
The package lam has a epoch 2 which is the reason the buildrequires test fails.

Version-Release number of selected component (if applicable):


How reproducible: always


Steps to Reproduce:
1. download blacs*.src.rpm on a RHEL3/4 machine
2. try to do a rpmbuild
3.
  
Actual results:
rpmbuild does not fail even though the version of lam on these systems is less
than required
# rpm -q lam
lam-7.0.6-5


Expected results:
rpmbuild should fail with:
[root@localhost SPECS]# rpmbuild -bp blacs.spec
error: Failed build dependencies:
        lam >= 2:7.1.1-5 is needed by blacs-1.1-18.i386


Additional info:

Comment 1 Saurabh Bathe 2006-02-16 14:43:47 UTC
forgot to mention, the buildrequires should include epoch
lam >= 2:7.1.1-5



Comment 2 Tom "spot" Callaway 2006-04-07 18:32:05 UTC
Resolved in blacs 1.1-20.