Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 181775 - spec file correction so that rpmbuild works as expected on RHEL systems
spec file correction so that rpmbuild works as expected on RHEL systems
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: blacs (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-16 09:37 EST by Saurabh Bathe
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-07 14:32:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saurabh Bathe 2006-02-16 09:37:06 EST
Description of problem: The buildrequires for lam in spec file seems to be
incorrect. The build should fail for RHEL3/4 but it does not.
The package lam has a epoch 2 which is the reason the buildrequires test fails.

Version-Release number of selected component (if applicable):


How reproducible: always


Steps to Reproduce:
1. download blacs*.src.rpm on a RHEL3/4 machine
2. try to do a rpmbuild
3.
  
Actual results:
rpmbuild does not fail even though the version of lam on these systems is less
than required
# rpm -q lam
lam-7.0.6-5


Expected results:
rpmbuild should fail with:
[root@localhost SPECS]# rpmbuild -bp blacs.spec
error: Failed build dependencies:
        lam >= 2:7.1.1-5 is needed by blacs-1.1-18.i386


Additional info:
Comment 1 Saurabh Bathe 2006-02-16 09:43:47 EST
forgot to mention, the buildrequires should include epoch
lam >= 2:7.1.1-5

Comment 2 Tom "spot" Callaway 2006-04-07 14:32:05 EDT
Resolved in blacs 1.1-20.

Note You need to log in before you can comment on or make changes to this bug.