Bug 1818978

Summary: ts-loader can use wrong tsconfig.json during builds, causing various runtime errors in console
Product: OpenShift Container Platform Reporter: Samuel Padgett <spadgett>
Component: Management ConsoleAssignee: Samuel Padgett <spadgett>
Status: CLOSED ERRATA QA Contact: Yadan Pei <yapei>
Severity: urgent Docs Contact:
Priority: high    
Version: 4.3.zCC: anarayan, aos-bugs, bpeterse, ebenahar, fbalak, jdelft, jokerman, rnetser, spadgett, sponnaga, tjelinek, vlaad, wsun, xiaocwan, yanpzhan, yapei
Target Milestone: ---Keywords: Regression
Target Release: 4.4.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
A bug in OpenShift console builds could occasionally result in runtime errors on certain pages. The bug has since been fixed.
Story Points: ---
Clone Of: 1811886
: 1818980 (view as bug list) Environment:
Last Closed: 2020-05-13 22:01:42 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1811886    
Bug Blocks: 1818980    

Comment 1 Jakub Hadvig 2020-03-31 09:02:08 UTC
*** Bug 1819045 has been marked as a duplicate of this bug. ***

Comment 4 Yadan Pei 2020-04-07 09:16:20 UTC
The fix PR for release-4.4 was merged 4 days ago, search https://search.svc.ci.openshift.org/?search=rangeerror&maxAge=48h&context=10&type=build-log returns empty results, no more RangeError: "invalid array length" 

Moving to VERIFIED

Comment 6 errata-xmlrpc 2020-05-13 22:01:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581