Bug 1818978 - ts-loader can use wrong tsconfig.json during builds, causing various runtime errors in console
Summary: ts-loader can use wrong tsconfig.json during builds, causing various runtime ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.3.z
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: ---
: 4.4.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1819045 (view as bug list)
Depends On: 1811886
Blocks: 1818980
TreeView+ depends on / blocked
 
Reported: 2020-03-30 20:21 UTC by Samuel Padgett
Modified: 2020-05-13 22:01 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
A bug in OpenShift console builds could occasionally result in runtime errors on certain pages. The bug has since been fixed.
Clone Of: 1811886
: 1818980 (view as bug list)
Environment:
Last Closed: 2020-05-13 22:01:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4858 None closed [release-4.4] Bug 1818978: Specify ts-loader configFile in webpack.config.ts 2020-04-24 16:05:37 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-13 22:01:45 UTC

Comment 1 Jakub Hadvig 2020-03-31 09:02:08 UTC
*** Bug 1819045 has been marked as a duplicate of this bug. ***

Comment 4 Yadan Pei 2020-04-07 09:16:20 UTC
The fix PR for release-4.4 was merged 4 days ago, search https://search.svc.ci.openshift.org/?search=rangeerror&maxAge=48h&context=10&type=build-log returns empty results, no more RangeError: "invalid array length" 

Moving to VERIFIED

Comment 6 errata-xmlrpc 2020-05-13 22:01:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.