Bug 1819892

Summary: Console shows 'Error Retrieving' for Update Status when Last Completed Version is not found in update service
Product: OpenShift Container Platform Reporter: Carvel Baus <cbaus>
Component: Management ConsoleAssignee: Robb Hamilton <rhamilto>
Status: CLOSED ERRATA QA Contact: Yadan Pei <yapei>
Severity: low Docs Contact:
Priority: unspecified    
Version: 4.3.zCC: aos-bugs, jokerman, yanpzhan
Target Milestone: ---   
Target Release: 4.5.0   
Hardware: s390x   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Cause: The console displays an inaccurate update status of `Error Retrieving` when the version does not appear in the update channel. Consequence: `Error Retrieving` suggests the version should be available but isn't. Fix: Update the console to display `Version not found` in the case where the version does not appear in the update channel. Result: Console displays `Version not found` when the version does not appear in the update channel.
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-07-13 17:24:45 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Carvel Baus 2020-04-01 19:53:22 UTC
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.149 Safari/537.36
Build Identifier: 

When the Last Completed Version of a cluster is not found in the update service, an error is reported on the console. This is actually not an error with the cluster itself but a [possibly] missing version in the upgrade service itself.  

Reproducible: Always

Steps to Reproduce:
1. Install cluster from a nightly build 
2. Examine Administration > Cluster Settings
3. Update Status will show 'Error Retrieving'
Actual Results:  
'Error Retrieving'

Expected Results:  
Cluster should report 'Version Not Found' or 'Upgrade Not Available' instead of reporting an error as it's not an error with the cluster itself.

Comment 1 Abhinav Dahiya 2020-04-06 16:45:11 UTC
So unable to find the version of the cluster in update service is most definitely an error. Because that blocks CVO functionality to fetch the available updates for upgrade.. that is core to the openshift.

So moving to console team to either show that error differently if they like, so close this BZ.

Comment 2 Carvel Baus 2020-04-06 18:04:35 UTC
I think there is a distinction though that wasn't clear from what I wrote. Not finding a version that IS in the update service would be an error (i.e. network/system outage, something else), but is NOT finding a version that IS NOT in the update service also the same error? I don't think they are the same. 

Perhaps it is simply a distinction made at the UI, but the CVO would need to make that distinction for the UI to also be aware.

Comment 3 Robb Hamilton 2020-05-07 18:43:47 UTC
Moving to upcoming sprint as there are many bugs.

Comment 6 Yanping Zhang 2020-05-14 02:57:48 UTC
Checked on OCP 4.5 cluster with payload 4.5.0-0.nightly-2020-05-13-202437.
Go to Administration > Cluster Settings page, the channel is "stable-4.5", and "Update Status" shows "Version not found", hover on it, there is info: Unable to retrieve available updates: currently installed version 4.5.0-0.nightly-2020-05-13-202437 not found in the "stable-4.5" channel.
The bug is fixed.

Comment 8 errata-xmlrpc 2020-07-13 17:24:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409