Bug 1823142

Summary: rpmlib(PayloadIsZstd) <= 5.4.18-1 is needed
Product: [Fedora] Fedora EPEL Reporter: Germano Massullo <germano.massullo>
Component: mockAssignee: Copr Team <copr-team>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: epel8CC: copr-team, jdisnard, jkeating, mebrown, msuchy, ngompa13, philip.wyett, praiskup, williams
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-04-12 00:43:51 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Description Flags
mock log none

Description Germano Massullo 2020-04-11 23:34:48 UTC
Created attachment 1678161 [details]
mock log

Description of problem:
while running mock on CentOS 8 I am getting a lot of messages like
rpmlib(PayloadIsZstd) <= 5.4.18-1 is needed by foo_package


Full log attached

Comment 1 Neal Gompa 2020-04-12 00:43:51 UTC
This is only because rpm in RHEL/CentOS 8 currently does not support zstd payloads. This will be fixed with RHEL/CentOS 8.2. Alternatively, you can upgrade to CentOS Stream and get the fix now.

rpm-4.14.2-36.el8 has the functionality available.

Comment 2 Pavel Raiskup 2020-04-12 06:18:57 UTC
Or you can update mock to 2.2 (epel-testing), and use --use-bootstrap-image