Bug 1823142 - rpmlib(PayloadIsZstd) <= 5.4.18-1 is needed
Summary: rpmlib(PayloadIsZstd) <= 5.4.18-1 is needed
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: mock
Version: epel8
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Copr Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-11 23:34 UTC by Germano Massullo
Modified: 2020-04-12 06:18 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-12 00:43:51 UTC
Type: Bug


Attachments (Terms of Use)
mock log (127.01 KB, text/plain)
2020-04-11 23:34 UTC, Germano Massullo
no flags Details

Description Germano Massullo 2020-04-11 23:34:48 UTC
Created attachment 1678161 [details]
mock log

Description of problem:
while running mock on CentOS 8 I am getting a lot of messages like
rpmlib(PayloadIsZstd) <= 5.4.18-1 is needed by foo_package

mock-1.4.21-1.el8.noarch

Full log attached

Comment 1 Neal Gompa 2020-04-12 00:43:51 UTC
This is only because rpm in RHEL/CentOS 8 currently does not support zstd payloads. This will be fixed with RHEL/CentOS 8.2. Alternatively, you can upgrade to CentOS Stream and get the fix now.

rpm-4.14.2-36.el8 has the functionality available.

Comment 2 Pavel Raiskup 2020-04-12 06:18:57 UTC
Or you can update mock to 2.2 (epel-testing), and use --use-bootstrap-image
option:
https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-5a84e15907


Note You need to log in before you can comment on or make changes to this bug.