Bug 1829341

Summary: out of order input fields in Importing VM from Red Hat Virtualization form
Product: OpenShift Container Platform Reporter: Matt <mcarleto>
Component: Console Kubevirt PluginAssignee: Yaacov Zamir <yzamir>
Status: CLOSED ERRATA QA Contact: Nelly Credi <ncredi>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 4.5CC: aos-bugs, gouyang, yzamir
Target Milestone: ---   
Target Release: 4.5.0   
Hardware: All   
OS: All   
Whiteboard:
Fixed In Version: Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-07-13 17:32:50 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Matt 2020-04-29 12:15:47 UTC
Description of problem:
When importing from RHV the user needs to provide credentials (Username, Password, CA Certificate). The action to submit these fields is out of order. For users who are tabbing especially this is difficult because there is a field required to connect that is after the action to connect so they would be confused.

Version-Release number of selected component (if applicable):


How reproducible:
very

Steps to Reproduce:
1. import a VM
2. Select from RHV
3. Enter credentials to log in

Actual results:
User needs to provide CA Certificate after the check action for the credentials but is required to enter the certificate first.

Expected results:
The CA certificate should come before the "Check" action

Additional info:
Screen recording
https://recordit.co/KdX8K4vG42

Comment 3 Guohua Ouyang 2020-05-27 08:17:25 UTC
verified on upstream 4.5 branch, commit 88b7689b0fb3dfc557d9e06dc509952b9233661e.

Comment 4 errata-xmlrpc 2020-07-13 17:32:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409