Bug 1829341 - out of order input fields in Importing VM from Red Hat Virtualization form
Summary: out of order input fields in Importing VM from Red Hat Virtualization form
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.5
Hardware: All
OS: All
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Yaacov Zamir
QA Contact: Nelly Credi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-29 12:15 UTC by Matt
Modified: 2020-07-13 17:33 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:32:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5471 0 None closed Bug 1829341: Move cert input field after url input field in ovirt import wizard 2020-06-24 01:28:34 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:33:01 UTC

Description Matt 2020-04-29 12:15:47 UTC
Description of problem:
When importing from RHV the user needs to provide credentials (Username, Password, CA Certificate). The action to submit these fields is out of order. For users who are tabbing especially this is difficult because there is a field required to connect that is after the action to connect so they would be confused.

Version-Release number of selected component (if applicable):


How reproducible:
very

Steps to Reproduce:
1. import a VM
2. Select from RHV
3. Enter credentials to log in

Actual results:
User needs to provide CA Certificate after the check action for the credentials but is required to enter the certificate first.

Expected results:
The CA certificate should come before the "Check" action

Additional info:
Screen recording
https://recordit.co/KdX8K4vG42

Comment 3 Guohua Ouyang 2020-05-27 08:17:25 UTC
verified on upstream 4.5 branch, commit 88b7689b0fb3dfc557d9e06dc509952b9233661e.

Comment 4 errata-xmlrpc 2020-07-13 17:32:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.