Bug 1838659

Summary: Accessing Yaml tab throws error on Safari browser
Product: OpenShift Container Platform Reporter: Christoph Jerolimov <cjerolim>
Component: Dev ConsoleAssignee: Christoph Jerolimov <cjerolim>
Status: CLOSED ERRATA QA Contact: Gajanan More <gamore>
Severity: high Docs Contact:
Priority: unspecified    
Version: 4.5CC: aos-bugs, nmukherj, spadgett
Target Milestone: ---   
Target Release: 4.5.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Cause: JavaScript exception because of on non standard behavior in Safari. Consequence: White screen when editing a yaml file in the Topology (only in Safari). Fix: Refactoring code so that it works also in Safari. Result: Editing a yaml file works now also in Safari browser.
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-07-13 17:40:55 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1838815    

Description Christoph Jerolimov 2020-05-21 14:14:50 UTC
Description of problem (by Abhishek):
Accessing Yaml tab under resource details page from various flows throws error

Version-Release number of selected component (if applicable):
4.5.0-0.nightly-2020-05-20-221742

How reproducible:
Always

Steps to Reproduce:
1. Launch Dev console in Safari browser
2. Switch to Developer perspective
3. Navigate to Topology & select a project which has workloads
4. Right-click on any workload & select `Edit <resource>` option from context menu

Actual results:
Yaml tab keeps displaying loading animation but doesn't load the yaml


Expected results:
Yaml tab should display the yaml

Additional info:
Happens only on Safari in the production build.

Comment 1 Samuel Padgett 2020-05-21 15:14:16 UTC
Related webkit bug: https://bugs.webkit.org/show_bug.cgi?id=189914

Comment 4 errata-xmlrpc 2020-07-13 17:40:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409