Bug 1838815 - Accessing Yaml tab throws error on Safari browser
Summary: Accessing Yaml tab throws error on Safari browser
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.4.z
Assignee: Christoph Jerolimov
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On: 1838659
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-21 20:42 UTC by OpenShift BugZilla Robot
Modified: 2020-06-17 22:27 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: JavaScript exception because of on non standard behavior in Safari. Consequence: White screen when editing a yaml file in the Topology (only in Safari). Fix: Refactoring code so that it works also in Safari. Result: Editing a yaml file works now also in Safari browser.
Clone Of:
Environment:
Last Closed: 2020-06-17 22:26:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5528 0 None closed Bug 1838815: Fix "SyntaxError: Unexpected identifier 'e'" in Safari (production build only) 2020-06-18 16:01:26 UTC
Red Hat Product Errata RHBA-2020:2445 0 None None None 2020-06-17 22:27:01 UTC

Description OpenShift BugZilla Robot 2020-05-21 20:42:21 UTC
+++ This bug was initially created as a clone of Bug #1838659 +++

Description of problem (by Abhishek):
Accessing Yaml tab under resource details page from various flows throws error

Version-Release number of selected component (if applicable):
4.5.0-0.nightly-2020-05-20-221742

How reproducible:
Always

Steps to Reproduce:
1. Launch Dev console in Safari browser
2. Switch to Developer perspective
3. Navigate to Topology & select a project which has workloads
4. Right-click on any workload & select `Edit <resource>` option from context menu

Actual results:
Yaml tab keeps displaying loading animation but doesn't load the yaml


Expected results:
Yaml tab should display the yaml

Additional info:
Happens only on Safari in the production build.

--- Additional comment from spadgett@redhat.com on 2020-05-21 15:14:16 UTC ---

Related webkit bug: https://bugs.webkit.org/show_bug.cgi?id=189914

Comment 3 Jaivardhan Kumar 2020-06-01 05:48:11 UTC
Validated on 

OS : MAC OSX
Browser : Safari Version 13.1 (15609.1.20.111.8)
Build Version: 4.5.0-0.nightly-2020-05-30-025738

Comment 4 Gajanan More 2020-06-01 06:27:43 UTC
@jakumar@redhat.com Can you please verify it on the 4.4.z as the target release is 4.4.z. The latest nightly build (https://openshift-release.svc.ci.openshift.org/releasestream/4.4.0-0.nightly/release/4.4.0-0.nightly-2020-06-01-021027) could be the perfect candidate to verify this bug.

Comment 5 Jaivardhan Kumar 2020-06-01 08:28:43 UTC


Validated on 

OS : MAC OSX
Browser : Safari Version 13.1 (15609.1.20.111.8)
Build Version: 4.4.0-0.nightly-2020-06-01-021027

Comment 9 errata-xmlrpc 2020-06-17 22:26:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2445


Note You need to log in before you can comment on or make changes to this bug.