Bug 1840954

Summary: Clicking on task gives white window
Product: OpenShift Container Platform Reporter: OpenShift BugZilla Robot <openshift-bugzilla-robot>
Component: Dev ConsoleAssignee: Andrew Ballantyne <aballant>
Status: CLOSED ERRATA QA Contact: spathak <spathak>
Severity: high Docs Contact:
Priority: unspecified    
Version: 4.5CC: aos-bugs, cvogt, nmukherj, spathak
Target Milestone: ---   
Target Release: 4.4.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Cause: Clicking on a Task bubble in the Pipeline Builder that could not find the associated task didn't have null safety coded Consequence: Whitescreened the app when it hit the error. Fix: Convert the node into a list node giving the user easy access to change it in place (otherwise they would have to delete and then try to insert it back - which could be very difficult in some cases) Result: The user has an easier flow to updating Task references that are no longer pointing at a Task/ClusterTask resource
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-06-17 22:26:40 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1839883    
Bug Blocks:    
Attachments:
Description Flags
Clicking on task does not gives white window
none
4.4:Clicking on task does not gives white window none

Comment 3 spathak@redhat.com 2020-06-04 20:55:12 UTC
Created attachment 1695319 [details]
Clicking on task does not gives white window

Comment 4 spathak@redhat.com 2020-06-04 20:57:50 UTC
Verified on build version: 4.5.0-0.ci-2020-06-03-081958
Browser version: Firefox 73

Comment 5 spathak@redhat.com 2020-06-04 22:21:47 UTC
Created attachment 1695355 [details]
4.4:Clicking on task does not gives white window

Comment 6 spathak@redhat.com 2020-06-04 22:22:51 UTC
Verified on build version: 4.4.0-0.ci-2020-06-04-183035
Browser version: Firefox 73

Comment 8 errata-xmlrpc 2020-06-17 22:26:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2445