Bug 1839883 - Clicking on task gives white window
Summary: Clicking on task gives white window
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.5.0
Assignee: Andrew Ballantyne
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks: 1840954
TreeView+ depends on / blocked
 
Reported: 2020-05-25 20:13 UTC by Andrew Ballantyne
Modified: 2022-08-18 08:18 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Clicking on a Task bubble in the Pipeline Builder that could not find the associated task didn't have null safety coded Consequence: Whitescreened the app when it hit the error. Fix: Convert the node into a list node giving the user easy access to change it in place (otherwise they would have to delete and then try to insert it back - which could be very difficult in some cases) Result: The user has an easier flow to updating Task references that are no longer pointing at a Task/ClusterTask resource
Clone Of:
Environment:
Last Closed: 2020-07-13 17:41:29 UTC
Target Upstream Version:


Attachments (Terms of Use)
Clicking on task does not gives white window (29.44 KB, image/png)
2020-06-01 11:57 UTC, spathak@redhat.com
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5553 0 None closed Bug 1839883: Pipeline Builder supports invalid task refs 2020-06-30 18:04:28 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:41:45 UTC

Description Andrew Ballantyne 2020-05-25 20:13:29 UTC
Description of problem:
If a Pipeline has an invalid taskRef it can cause the Pipeline Builder to whitescreen the app.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Edit a Pipeline that references a task that does not exist (modify the YAML if needed)
2. Click on the task that references a Task that does not exist

Actual results:
White-screens the app

Expected results:
To handle gracefully a task that may not be referenceable.

Additional info:

Comment 4 spathak@redhat.com 2020-06-01 11:57:49 UTC
Created attachment 1694077 [details]
Clicking on task does not gives white window

Comment 5 spathak@redhat.com 2020-06-01 12:00:54 UTC
Verified on build version: 4.5.0-0.nightly-2020-05-31-230932
Browser version: Firefox 73  4.5.0-0.nightly-2020-05-31-230932

Comment 6 errata-xmlrpc 2020-07-13 17:41:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409

Comment 7 Alton Dean 2022-08-18 08:18:56 UTC
As a result of this increased growth, drift games are becoming more sophisticated, and players must be more attentive and responsive. They must succeed not only in terms of how long they can stare at the screen, but also in terms of predictability of where they will go
https://drift-boss.co/


Note You need to log in before you can comment on or make changes to this bug.