Bug 1850075

Summary: lasso: FTBFS: error: too few arguments to function '_ck_assert_failed'
Product: [Fedora] Fedora Reporter: Jitka Plesnikova <jplesnik>
Component: lassoAssignee: Simo Sorce <ssorce>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: igor.raits, jdennis, jhrozek, ppisar, rcritten, ssorce
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
URL: https://koschei.fedoraproject.org/package/lasso
Whiteboard:
Fixed In Version: lasso-2.6.1-1.fc33 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-07-03 17:28:13 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1803234, 1803235    

Description Jitka Plesnikova 2020-06-23 13:49:58 UTC
Description of problem:
Package lasso fails to build from source in Fedora rawhide with the error:

random_tests.c:49:2: error: too few arguments to function '_ck_assert_failed'
   49 |  fail_unless(LASSO_IS_PROVIDER(provider));
      |  ^~~~~~~~~~~

Version-Release number of selected component (if applicable):
2.6.0-22.fc33

Steps to Reproduce:
koji build --scratch f33 lasso-2.6.0-22.fc33.src.rpm

Comment 1 Petr Pisar 2020-06-30 12:13:54 UTC
*** Bug 1852143 has been marked as a duplicate of this bug. ***