Bug 1852249

Summary: failed to initialize the cluster: Cluster operator openshift-controller-manager is still updating (operator version not set)
Product: OpenShift Container Platform Reporter: Gabe Montero <gmontero>
Component: openshift-controller-managerAssignee: Gabe Montero <gmontero>
Status: CLOSED ERRATA QA Contact: wewang <wewang>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 4.3.zCC: adam.kaplan, aos-bugs, gmontero, mfojtik, pmuller, wewang, wking
Target Milestone: ---   
Target Release: 4.4.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: devex
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Cause: timing windows existed where the openshift controller manager operator would set its progressing condition to false even though it had not registered its version Consequence: the openshift controller manager operator would not fully satisfy its contract with the install/upgrade and the install/upgrade would ultimately fail Fix: the timing window which allowed progressing to be set to false prior to setting the version was corrected via code change Result: the openshift controller manager operator now more readily reports both its version and its progressing condition upon successful install/upgrade
Story Points: ---
Clone Of: 1814446
: 1854133 (view as bug list) Environment:
Last Closed: 2020-07-14 01:43:54 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1814446    
Bug Blocks: 1854133    

Comment 3 Gabe Montero 2020-07-06 13:29:07 UTC
https://search.apps.build01.ci.devcluster.openshift.com/?search=Cluster+operator+openshift-controller-manager+is+still+updating&maxAge=24h&context=2&type=all&name=4.4&maxMatches=5&maxBytes=20971520&groupBy=job comes up clean, with only our bz here
in the 2 days since this PR merged.  

Marking verified, moving onto 4.3 per ask from Trevor.

Comment 6 errata-xmlrpc 2020-07-14 01:43:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2871