Bug 1856573

Summary: Default filter alert state doesn't take effect when open monitoring alert page
Product: OpenShift Container Platform Reporter: hongyan li <hongyli>
Component: Management ConsoleAssignee: Andrew Pickering <anpicker>
Status: CLOSED ERRATA QA Contact: hongyan li <hongyli>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 4.6CC: alegrand, anpicker, aos-bugs, erooth, jokerman, kakkoyun, lcosic, mloibl, pkrupa, surbania
Target Milestone: ---   
Target Release: 4.6.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-10-27 16:14:10 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Screenshot with alert state filter and wrong alerts display
none
Verification screenshot none

Description hongyan li 2020-07-14 01:56:54 UTC
Description of problem:
Open openshift console, open Monitoring->Alerting
There is Alert filter on page with state firing
Alerts with non firing state, such as silenced alert also display

Version-Release number of selected component (if applicable):
4.6.0-0.nightly-2020-07-13-203610

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:
Silenced alerts displays

Expected results:
Only display Firing alerts

Additional info:

Comment 1 hongyan li 2020-07-14 01:59:19 UTC
Created attachment 1700925 [details]
Screenshot with alert state filter and wrong alerts display

Comment 4 XiaochuanWang 2020-07-22 09:04:36 UTC
Created attachment 1702037 [details]
Verification screenshot

Comment 5 XiaochuanWang 2020-07-22 09:05:48 UTC
Attached screenshot, alerts list display as expected.
Verified on 4.6.0-0.nightly-2020-07-22-031913

Comment 7 errata-xmlrpc 2020-10-27 16:14:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196