Bug 1856573 - Default filter alert state doesn't take effect when open monitoring alert page
Summary: Default filter alert state doesn't take effect when open monitoring alert page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.6.0
Assignee: Andrew Pickering
QA Contact: hongyan li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-14 01:56 UTC by hongyan li
Modified: 2020-10-27 16:14 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:14:10 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot with alert state filter and wrong alerts display (144.30 KB, image/png)
2020-07-14 01:59 UTC, hongyan li
no flags Details
Verification screenshot (196.73 KB, image/png)
2020-07-22 09:04 UTC, XiaochuanWang
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6043 0 None closed Bug 1856573: Monitoring: Fix FilterToolbar's defaultSelected handling 2020-10-04 23:47:12 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:14:24 UTC

Description hongyan li 2020-07-14 01:56:54 UTC
Description of problem:
Open openshift console, open Monitoring->Alerting
There is Alert filter on page with state firing
Alerts with non firing state, such as silenced alert also display

Version-Release number of selected component (if applicable):
4.6.0-0.nightly-2020-07-13-203610

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:
Silenced alerts displays

Expected results:
Only display Firing alerts

Additional info:

Comment 1 hongyan li 2020-07-14 01:59:19 UTC
Created attachment 1700925 [details]
Screenshot with alert state filter and wrong alerts display

Comment 4 XiaochuanWang 2020-07-22 09:04:36 UTC
Created attachment 1702037 [details]
Verification screenshot

Comment 5 XiaochuanWang 2020-07-22 09:05:48 UTC
Attached screenshot, alerts list display as expected.
Verified on 4.6.0-0.nightly-2020-07-22-031913

Comment 7 errata-xmlrpc 2020-10-27 16:14:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.