Bug 1868427

Summary: [Kuryr] Pods not getting annotated due to controller missing events
Product: OpenShift Container Platform Reporter: Michał Dulko <mdulko>
Component: NetworkingAssignee: Michał Dulko <mdulko>
Networking sub component: kuryr QA Contact: GenadiC <gcheresh>
Status: CLOSED ERRATA Docs Contact:
Severity: high    
Priority: high CC: bbennett, gcheresh, juriarte, ltomasbo, openshift-bugzilla-robot, rlobillo
Version: 4.4   
Target Milestone: ---   
Target Release: 4.4.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: 1853215 Environment:
Last Closed: 2020-08-25 06:20:31 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1853215    
Bug Blocks:    

Comment 4 Jon Uriarte 2020-08-18 12:41:28 UTC
Verified in 4.4.0-0.nightly-2020-08-15-035358 on top of OSP 16.1 RHOS-16.1-RHEL-8-20200804.n.0 compose.

The OCP cluster with Kuryr was successfully installed 3 times in a row, the clusters are working
without the need to restart the kuryr controller pod.

Comment 6 errata-xmlrpc 2020-08-25 06:20:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.4.18 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3440