Bug 1853215 - [Kuryr] Pods not getting annotated due to controller missing events
Summary: [Kuryr] Pods not getting annotated due to controller missing events
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.5.z
Assignee: Michał Dulko
QA Contact: GenadiC
URL:
Whiteboard:
Depends On: 1847011
Blocks: 1868427
TreeView+ depends on / blocked
 
Reported: 2020-07-02 07:59 UTC by OpenShift BugZilla Robot
Modified: 2020-08-12 15:52 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1868427 (view as bug list)
Environment:
Last Closed: 2020-07-22 12:20:42 UTC
Target Upstream Version:


Attachments (Terms of Use)
logs for 3 successful installations (2.68 MB, application/gzip)
2020-07-21 07:39 UTC, rlobillo
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift kuryr-kubernetes pull 297 None closed [release-4.5] Bug 1853215: Periodically fetch full list of watched resources 2020-09-02 07:10:35 UTC
Red Hat Product Errata RHBA-2020:2956 None None None 2020-07-22 12:21:05 UTC

Description OpenShift BugZilla Robot 2020-07-02 07:59:01 UTC
+++ This bug was initially created as a clone of Bug #1847011 +++

Description of problem:

Under certain scenarios the pods not running on hostNetwork can get stuck on phase ContainerCreating due to missing the kuryr annotation. The addition of the annotation is missed due to the event not being handled by the controller.

Version-Release number of selected component (if applicable):
OCP 4.5
Red Hat OpenStack Platform release 16.1
OVN

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from bbennett@redhat.com on 2020-06-15 14:31:54 UTC ---

Setting the target release to the current development branch.  Once a fix has been identified we can work out whether it is safe to backport.

Comment 5 rlobillo 2020-07-21 07:39:14 UTC
Created attachment 1701853 [details]
logs for 3 successful installations

Comment 6 rlobillo 2020-07-21 07:40:52 UTC
Verified in 4.5.0-0.nightly-2020-07-20-152128 on top of OSP16.1, RHOS-16.1-RHEL-8-20200714.n.0 compose.

The OCP cluster with Kuryr was successfully installed 3 times in a row, the clusters are working
without the need to restart the kuryr controller pod.

Installation logs attached.

Comment 9 errata-xmlrpc 2020-07-22 12:20:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2956


Note You need to log in before you can comment on or make changes to this bug.