Bug 1872336

Summary: PipelineRun created by Trigger should have a unique id
Product: OpenShift Container Platform Reporter: Christoph Jerolimov <cjerolim>
Component: Dev ConsoleAssignee: Christoph Jerolimov <cjerolim>
Status: CLOSED ERRATA QA Contact: Gajanan More <gamore>
Severity: high Docs Contact:
Priority: unspecified    
Version: 4.6CC: aballant, aos-bugs, nmukherj
Target Milestone: ---   
Target Release: 4.6.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-10-27 16:32:46 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1878849    

Description Christoph Jerolimov 2020-08-25 14:06:53 UTC
Description of problem:
When I use a Pipeline Trigger and I test it out with Postman, it tried to create a PipelineRun with the same name everytime, resulting in an error.

Version-Release number of selected component (if applicable):
Pipelines Operator v1.0.1, OpenShift 4.5.0-rc.4

How reproducible:
Always

Steps to Reproduce:
1. Installed the Operator
2. Created a sample task. I replaced the $(input.params.appName) by a string to output hello world and removed the parameter appname
3. Created a pipeline with this task alone
4. Added a trigger using the "Add Trigger" option
5. Used the following payload in Postman (see request.json). The Payload is the payload created by Github to which I added a "name" property.
6. Did a POST request to the event listener URL
7. A PipelineRun was created and the pipeline ran
8. Tried the same request again
9. Got the following error message (see error.json)

Actual results:
Got an error message about the pipeline run already existing, the pipeline was not executed again.

Expected results:
The pipelinerun should have a unique id and should start the pipeline

Additional info:
None

Comment 1 Christoph Jerolimov 2020-08-25 14:07:38 UTC
Jira Issue: https://issues.redhat.com/browse/ODC-4236
GitHub PR: https://github.com/openshift/console/pull/6248

Comment 3 Andrew Ballantyne 2020-09-28 20:03:38 UTC
Verified on 4.6.0-0.nightly-2020-09-28-061045

Uses generateName instead of name in the PipelineRun that gets embedded in the TriggerTemplate.

Comment 6 errata-xmlrpc 2020-10-27 16:32:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196