Bug 1872520

Summary: Pruner degrades image registry operator if the latter is removed
Product: OpenShift Container Platform Reporter: OpenShift BugZilla Robot <openshift-bugzilla-robot>
Component: Image RegistryAssignee: Ricardo Maraschini <rmarasch>
Status: CLOSED ERRATA QA Contact: Wenjing Zheng <wzheng>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 4.5CC: aos-bugs, cpassare, lmohanty, obulatov, pasik, wking
Target Milestone: ---Keywords: Upgrades
Target Release: 4.4.z   
Hardware: All   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Cause: Prune enabled with image registry Removed Consequence: Pruner job failing because it fails to reach a registry that does not exist (Removed) Fix: Do not attempt to ping the registry if it is removed. Result: Pruner succeeds and removes only etcd objects (do not attempt to remove blobs)
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-10-13 08:17:44 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 1872519    
Bug Blocks:    

Comment 4 Wenjing Zheng 2020-09-28 05:04:20 UTC
$ oc logs pods/image-pruner-1601269320-4rktm
Only API objects will be removed.  No modifications to the image registry will be made.
Deleted 0 objects.
zhengwenjings-MacBook-Pro:4.4 wzheng$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.4.0-0.nightly-2020-09-26-200621

Verified as above info.

Comment 7 errata-xmlrpc 2020-10-13 08:17:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.4.27 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4063