Bug 1872519 - Pruner degrades image registry operator if the latter is removed
Summary: Pruner degrades image registry operator if the latter is removed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image Registry
Version: 4.5
Hardware: All
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 4.5.z
Assignee: Ricardo Maraschini
QA Contact: Wenjing Zheng
URL:
Whiteboard:
: 1877547 (view as bug list)
Depends On: 1867792
Blocks: 1872520
TreeView+ depends on / blocked
 
Reported: 2020-08-26 01:01 UTC by OpenShift BugZilla Robot
Modified: 2020-09-15 12:18 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-14 14:54:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift oc pull 532 None closed [release-4.5] Bug 1872519: Allow prune to move on with Removed registry 2020-09-14 15:01:41 UTC
Red Hat Product Errata RHBA-2020:3618 None None None 2020-09-14 14:55:00 UTC

Comment 4 Wenjing Zheng 2020-09-10 05:20:48 UTC
$ oc logs pods/image-pruner-1599715140-l4b27
Only API objects will be removed.  No modifications to the image registry will be made.
Deleted 0 objects.
$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.5.0-0.nightly-2020-09-07-062006   True        False         24h     Cluster version is 4.5.0-0.nightly-2020-09-07-062006

Comment 5 Ricardo Maraschini 2020-09-10 15:23:38 UTC
*** Bug 1877547 has been marked as a duplicate of this bug. ***

Comment 7 errata-xmlrpc 2020-09-14 14:54:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.9 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3618


Note You need to log in before you can comment on or make changes to this bug.