Bug 1875600

Summary: Removing default value for parameter from devconsole UI replaces default value with '' (empty string)
Product: OpenShift Container Platform Reporter: Debsmita Santra <dsantra>
Component: Dev ConsoleAssignee: Debsmita Santra <dsantra>
Status: CLOSED ERRATA QA Contact: spathak <spathak>
Severity: medium Docs Contact:
Priority: high    
Version: 4.6CC: aos-bugs, nmukherj, spathak
Target Milestone: ---   
Target Release: 4.6.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-10-27 16:37:52 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1881784    
Attachments:
Description Flags
Removing default value for parameter from devconsole UI does not replaces default value with '' (empty string) none

Description Debsmita Santra 2020-09-03 20:45:35 UTC
Description of problem:
Removing default value for parameter from devconsole UI replaces default value with '' (empty string)

Version-Release number of selected component (if applicable):
4.6

How reproducible:
Always

Steps to Reproduce:
1. Create a pipeline with parameter and provide a default value for the parameter
2. Navigate to devconsole UI > Pipelines  and select the above created pipeline 
3. Select the Parameters tab and remove the default value for parameter and click on save button

Actual results:
The default value of the  parameter gets updated as ''

Expected results:
The default value for the parameter should get removed

Additional info:

Comment 1 spathak@redhat.com 2020-09-23 07:54:13 UTC
Created attachment 1715932 [details]
Removing default value for parameter from devconsole UI does not replaces default value with '' (empty string)

Comment 2 spathak@redhat.com 2020-09-23 07:57:08 UTC
Verify on build version: 4.6.0-0.ci-2020-09-23-032326
Browser version: Firefox 70.0

Comment 5 errata-xmlrpc 2020-10-27 16:37:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196