Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1881784 - Removing default value for parameter from devconsole UI replaces default value with '' (empty string)
Summary: Removing default value for parameter from devconsole UI replaces default valu...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.5.z
Assignee: Debsmita Santra
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On: 1875600
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-23 05:15 UTC by OpenShift BugZilla Robot
Modified: 2020-10-12 15:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-12 15:48:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6715 0 None closed [release-4.5] Bug 1881784: fix empty default value for pipeline parameters 2020-09-29 13:24:17 UTC
Red Hat Product Errata RHBA-2020:3843 0 None None None 2020-10-12 15:48:19 UTC

Description OpenShift BugZilla Robot 2020-09-23 05:15:16 UTC
+++ This bug was initially created as a clone of Bug #1875600 +++

Description of problem:
Removing default value for parameter from devconsole UI replaces default value with '' (empty string)

Version-Release number of selected component (if applicable):
4.6

How reproducible:
Always

Steps to Reproduce:
1. Create a pipeline with parameter and provide a default value for the parameter
2. Navigate to devconsole UI > Pipelines  and select the above created pipeline 
3. Select the Parameters tab and remove the default value for parameter and click on save button

Actual results:
The default value of the  parameter gets updated as ''

Expected results:
The default value for the parameter should get removed

Additional info:

Comment 3 Gajanan More 2020-10-01 07:12:53 UTC
Verified on:
Build: 4.5.0-0.ci-2020-09-30-202106
Browser: Google Chrome 85.0.4183.102
Marking this as verified

Comment 5 errata-xmlrpc 2020-10-12 15:48:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.14 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3843


Note You need to log in before you can comment on or make changes to this bug.