Bug 1878173

Summary: running test of ImagePullPolicy in parallel with must-gather fails
Product: OpenShift Container Platform Reporter: jtanenba
Component: NetworkingAssignee: jtanenba
Networking sub component: ovn-kubernetes QA Contact: Anurag saxena <anusaxen>
Status: RELEASE_PENDING --- Docs Contact:
Severity: medium    
Priority: unspecified    
Version: 4.6   
Target Milestone: ---   
Target Release: 4.6.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description jtanenba 2020-09-11 14:20:07 UTC
Description of problem:

When running the test

[sig-arch] Managed cluster should ensure pods use downstream images from our release image with proper ImagePullPolicy

in parallel with another test running a must-gather causes this test to fail

fail [github.com/openshift/origin@/test/extended/operators/images.go:161]: Sep 3 13:35:56.971: Pods found with invalid container image pull policy not equal to IfNotPresent: openshift-must-gather-t6z56/must-gather-rp75x/copy imagePullPolicy=Always
openshift-must-gather-t6z56/must-gather-rp75x/gather imagePullPolicy=Always
openshift-must-gather-zv77v/must-gather-nwn8c/copy imagePullPolicy=Always
openshift-must-gather-zv77v/must-gather-nwn8c/gather imagePullPolicy=Always


Version-Release number of selected component (if applicable):


How reproducible:
always


Steps to Reproduce:
1. run [sig-arch] Managed cluster should ensure pods use downstream images from our release image with proper ImagePullPolicy
2. while that test is running run a must-gather


Actual results:

the must-gather operation causes the sig-arch test to fail 


Expected results:
the must-gather should not cause the sig-arch test to fail 

Additional info:

Comment 2 Anurag saxena 2020-09-15 20:01:20 UTC
Not seeing such issue on 4.6.0-0.nightly-2020-09-12-164537.