Bug 1878173 - running test of ImagePullPolicy in parallel with must-gather fails
Summary: running test of ImagePullPolicy in parallel with must-gather fails
Keywords:
Status: VERIFIED
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.6.0
Assignee: jtanenba
QA Contact: Anurag saxena
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-11 14:20 UTC by jtanenba
Modified: 2020-09-15 20:01 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift origin pull 25473 None closed Bug 1878173: running test of ImagePullPolicy in parallel with must-gather fails 2020-09-21 10:35:02 UTC

Description jtanenba 2020-09-11 14:20:07 UTC
Description of problem:

When running the test

[sig-arch] Managed cluster should ensure pods use downstream images from our release image with proper ImagePullPolicy

in parallel with another test running a must-gather causes this test to fail

fail [github.com/openshift/origin@/test/extended/operators/images.go:161]: Sep 3 13:35:56.971: Pods found with invalid container image pull policy not equal to IfNotPresent: openshift-must-gather-t6z56/must-gather-rp75x/copy imagePullPolicy=Always
openshift-must-gather-t6z56/must-gather-rp75x/gather imagePullPolicy=Always
openshift-must-gather-zv77v/must-gather-nwn8c/copy imagePullPolicy=Always
openshift-must-gather-zv77v/must-gather-nwn8c/gather imagePullPolicy=Always


Version-Release number of selected component (if applicable):


How reproducible:
always


Steps to Reproduce:
1. run [sig-arch] Managed cluster should ensure pods use downstream images from our release image with proper ImagePullPolicy
2. while that test is running run a must-gather


Actual results:

the must-gather operation causes the sig-arch test to fail 


Expected results:
the must-gather should not cause the sig-arch test to fail 

Additional info:

Comment 2 Anurag saxena 2020-09-15 20:01:20 UTC
Not seeing such issue on 4.6.0-0.nightly-2020-09-12-164537.


Note You need to log in before you can comment on or make changes to this bug.