Bug 1878173 - running test of ImagePullPolicy in parallel with must-gather fails
Summary: running test of ImagePullPolicy in parallel with must-gather fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.6.0
Assignee: Jacob Tanenbaum
QA Contact: Anurag saxena
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-11 14:20 UTC by Jacob Tanenbaum
Modified: 2020-10-27 16:40 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:40:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift origin pull 25473 0 None closed Bug 1878173: running test of ImagePullPolicy in parallel with must-gather fails 2020-09-21 10:35:02 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:40:24 UTC

Description Jacob Tanenbaum 2020-09-11 14:20:07 UTC
Description of problem:

When running the test

[sig-arch] Managed cluster should ensure pods use downstream images from our release image with proper ImagePullPolicy

in parallel with another test running a must-gather causes this test to fail

fail [github.com/openshift/origin@/test/extended/operators/images.go:161]: Sep 3 13:35:56.971: Pods found with invalid container image pull policy not equal to IfNotPresent: openshift-must-gather-t6z56/must-gather-rp75x/copy imagePullPolicy=Always
openshift-must-gather-t6z56/must-gather-rp75x/gather imagePullPolicy=Always
openshift-must-gather-zv77v/must-gather-nwn8c/copy imagePullPolicy=Always
openshift-must-gather-zv77v/must-gather-nwn8c/gather imagePullPolicy=Always


Version-Release number of selected component (if applicable):


How reproducible:
always


Steps to Reproduce:
1. run [sig-arch] Managed cluster should ensure pods use downstream images from our release image with proper ImagePullPolicy
2. while that test is running run a must-gather


Actual results:

the must-gather operation causes the sig-arch test to fail 


Expected results:
the must-gather should not cause the sig-arch test to fail 

Additional info:

Comment 2 Anurag saxena 2020-09-15 20:01:20 UTC
Not seeing such issue on 4.6.0-0.nightly-2020-09-12-164537.

Comment 5 errata-xmlrpc 2020-10-27 16:40:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.