Bug 188347

Summary: Removing and adding default printer again results in broken setup
Product: [Fedora] Fedora Reporter: Hans de Goede <hdegoede>
Component: system-config-printerAssignee: Tim Waugh <twaugh>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-06-20 13:32:10 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Hans de Goede 2006-04-08 07:34:18 UTC
Because of some other printing problems I'm having I did the following:
-remove default printer (a usb connected HPC1350 for which a have a bw and a 
 color queue, the bw queue is the default)
-do NOT apply this
-add exactly the same queue again make it default
-apply

Result:
No <DefaultPrinter xxx> in /etc/cups/printers.conf, actually no entry at all for
the added/removed queue in /etc/cups/printers.conf. lpq gives an error that
there is no default printer.

Comment 1 Tim Waugh 2006-06-20 13:32:10 UTC
What version of system-config-printer?  Sounds like you aren't trying the
re-written system-config-printer, and instead got the old one.

Could you re-test please, and re-open this bug if you still see the problem?

Comment 2 Hans de Goede 2006-06-20 17:12:04 UTC
Erm,

I just fired up system-config-printer on my fully updated rawhide box (I wanted
to test test1) and it looks like a full rewrite, is it relevant to retest this
under this completly new version?