Bug 188347 - Removing and adding default printer again results in broken setup
Removing and adding default printer again results in broken setup
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-08 03:34 EDT by Hans de Goede
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-20 09:32:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2006-04-08 03:34:18 EDT
Because of some other printing problems I'm having I did the following:
-remove default printer (a usb connected HPC1350 for which a have a bw and a 
 color queue, the bw queue is the default)
-do NOT apply this
-add exactly the same queue again make it default
-apply

Result:
No <DefaultPrinter xxx> in /etc/cups/printers.conf, actually no entry at all for
the added/removed queue in /etc/cups/printers.conf. lpq gives an error that
there is no default printer.
Comment 1 Tim Waugh 2006-06-20 09:32:10 EDT
What version of system-config-printer?  Sounds like you aren't trying the
re-written system-config-printer, and instead got the old one.

Could you re-test please, and re-open this bug if you still see the problem?
Comment 2 Hans de Goede 2006-06-20 13:12:04 EDT
Erm,

I just fired up system-config-printer on my fully updated rawhide box (I wanted
to test test1) and it looks like a full rewrite, is it relevant to retest this
under this completly new version?

Note You need to log in before you can comment on or make changes to this bug.