Bug 18851

Summary: Install crashes after fdisk-phase
Product: [Retired] Red Hat Linux Reporter: Nils Martin Fredriksen <nilsf>
Component: anacondaAssignee: Michael Fulbright <msf>
Status: CLOSED DUPLICATE QA Contact: Brock Organ <borgan>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-10-18 20:36:40 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Nils Martin Fredriksen 2000-10-10 21:00:03 UTC
My wife's system has 2 ide harddisks, one 13GB wd drive with Win95 as
master, and one 6GB Quantum drive as slave. I tried to install RH7 to the
second hd after much selling the idea of using a great OS. Of course, as I
got permission to go ahead Murphy just had to drop by.

During install I can't use Disk Druid. It pushes "/" down to the very
latest part of the disk, and I seem to recall LILO doesn't support this.
(And, it's untidy. I'm a pedant...)

All looks great with fdisk though. But after fdisk anaconda stops with
grave error messages and asks me to send the appended text to bugzilla. And
as I'm anacondas faithful servant, here you go!
---
Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line
20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1472, in
doInstall
    self.fstab.mountFilesystems (self.instPath)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 713, in
mountFilesystems
    raise SystemError, (errno, msg)
SystemError: (22, 'Ugyldig argument')

Local variables in innermost frame:
size: 104391
fsystem: ext2
self: <fstab.GuiFstab instance at 8446ca0>
msg: Ugyldig argument
doFormat: 1
errno: 22
device: hdb1
instPath: /mnt/sysimage
mntpoint: /

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>

Comment 1 Need Real Name 2000-10-11 01:30:03 UTC
Same error as bug <a href="http://bugzilla.redhat.com/bugzilla/show_bug.cgi?
id=18724">18724</a>

Comment 2 JasonC 2000-10-11 04:27:14 UTC
I have the same problem. Setup is as follows:

- PII/300 (overclocked to 338 <g>).
- 128MB RAM
- 10.2 GB HDD
- ATI FURY 128

Error I consistently get:
----------------------------------
Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line 20, 
in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in 
doInstall
    if self.method.systemMounted (self.fstab, self.instPath, 
self.hdList.selected()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 46, in 
systemMounted
    self.loopbackFile = mntPoint + fstab.filesystemSpace(mntPoint)[0][0] + \
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 258, in 
filesystemSpace
    space.append((mntpoint, isys.fsSpaceAvailable(topMount + '/' + mntpoint)))
  File "/usr/lib/anaconda/isys.py", line 16, in fsSpaceAvailable
    return _isys.devSpaceFree(fsystem)
SystemError: (2, 'No such file or directory')

Local variables in innermost frame:
fsystem: /mnt/sysimage//mnt/SAMHAIN/c

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
--------------------------

Any help would be appreciated! Thanks,



Comment 3 Michael Fulbright 2000-10-18 20:36:37 UTC

*** This bug has been marked as a duplicate of 16686 ***