Bug 1886023

Summary: There should be a strict requirement for the Ansible version
Product: Red Hat Satellite Reporter: Ondrej Gajdusek <ogajduse>
Component: PackagingAssignee: Evgeni Golov <egolov>
Status: CLOSED ERRATA QA Contact: Ondrej Gajdusek <ogajduse>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 6.8.0CC: egolov, zhunting
Target Milestone: 6.9.0Keywords: EasyFix, Triaged
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
Fixed In Version: satellite-6.9.0-0.2.beta Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-04-21 13:18:20 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Ondrej Gajdusek 2020-10-07 13:34:25 UTC
Description of problem:
None of the base Satelite/Capsule packages strictly requires ansible-2.9. Documentation tells customer to enable rhel-7-server-ansible-2.9-rpms repository 
thus I assume that this is a strict requirement. If customers do not enable this repository, they will end up with ansible- installed from the Satellite Maintenance repository not with ansible-2.9.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.rpm -q --whatrequires ansible | grep el7sat | xargs rpm -qR | sort -u | grep ansible

Actual results:
No package requires ansible-2.9 to be installed.

Expected results:
There should be some package that would force installing ansible-2.9.

Additional info:

Comment 2 Ondrej Gajdusek 2020-10-07 14:20:48 UTC
The reproducer is not quite accurate.

The package that should set the requirement for the ansible package is: tfm-rubygem-smart_proxy_ansible.

$ rpm -qR tfm-rubygem-smart_proxy_ansible | grep ^ansible

Actual: ansible >= 2.2
Expected: ansible >= 2.9

Comment 3 Evgeni Golov 2020-10-19 14:43:48 UTC
Notes from the triage session:
* the 2.9 requirement is Red Hat support/QE only (we only support that version of ansible in 6.8, the underlying code is probably working with other versions fine)
* >= 2.9 would include 2.10, which we don't support either
* proposal to add a "Requires: ansible >= 2.9, Requires: ansible < 2.10" to the satellite and satellite-capsule RPMs Red Hat ships.

Comment 4 Evgeni Golov 2020-10-19 14:44:18 UTC
Or maybe not capsule, as we don't enable ansible on capsules by default?

Comment 5 Evgeni Golov 2020-11-20 10:18:23 UTC
(In reply to Evgeni Golov from comment #4)
> Or maybe not capsule, as we don't enable ansible on capsules by default?

our docs say to enable ansible repo on capsule too, so I went and added the dependency to satellite-common

Comment 6 Brad Buckingham 2021-01-08 20:13:39 UTC
Satellite 6.9 SNAP 8 currently has satellite-6.9.0-0.3.beta.el7sat.noarch.  Based upon the 'fixed in version', aligning to 6.9 and updating status.

Comment 7 Ondrej Gajdusek 2021-02-18 09:05:48 UTC
Package satellite-common now requires ansible being installed. This has an effect on Satellite as well as Satellite capsules.

$ rpm -qR satellite-common
ansible < 2.10
ansible >= 2.9

Comment 10 errata-xmlrpc 2021-04-21 13:18:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Moderate: Satellite 6.9 Release), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.