Bug 1886023 - There should be a strict requirement for the Ansible version
Summary: There should be a strict requirement for the Ansible version
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Packaging
Version: 6.8.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: 6.9.0
Assignee: Evgeni Golov
QA Contact: Ondrej Gajdusek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-07 13:34 UTC by Ondrej Gajdusek
Modified: 2021-04-21 13:18 UTC (History)
2 users (show)

Fixed In Version: satellite-6.9.0-0.2.beta
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-04-21 13:18:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2021:1313 0 None None None 2021-04-21 13:18:38 UTC

Description Ondrej Gajdusek 2020-10-07 13:34:25 UTC
Description of problem:
None of the base Satelite/Capsule packages strictly requires ansible-2.9. Documentation tells customer to enable rhel-7-server-ansible-2.9-rpms repository 
thus I assume that this is a strict requirement. If customers do not enable this repository, they will end up with ansible-2.4.2.0-2.el7.noarch.rpm installed from the Satellite Maintenance repository not with ansible-2.9.

Version-Release number of selected component (if applicable):
satellite-6.8.0-1.el7sat.noarch

How reproducible:
always


Steps to Reproduce:
1.rpm -q --whatrequires ansible | grep el7sat | xargs rpm -qR | sort -u | grep ansible

Actual results:
No package requires ansible-2.9 to be installed.


Expected results:
There should be some package that would force installing ansible-2.9.

Additional info:

Comment 2 Ondrej Gajdusek 2020-10-07 14:20:48 UTC
The reproducer is not quite accurate.

The package that should set the requirement for the ansible package is: tfm-rubygem-smart_proxy_ansible.

$ rpm -qR tfm-rubygem-smart_proxy_ansible | grep ^ansible

Actual: ansible >= 2.2
Expected: ansible >= 2.9

Comment 3 Evgeni Golov 2020-10-19 14:43:48 UTC
Notes from the triage session:
* the 2.9 requirement is Red Hat support/QE only (we only support that version of ansible in 6.8, the underlying code is probably working with other versions fine)
* >= 2.9 would include 2.10, which we don't support either
* proposal to add a "Requires: ansible >= 2.9, Requires: ansible < 2.10" to the satellite and satellite-capsule RPMs Red Hat ships.

Comment 4 Evgeni Golov 2020-10-19 14:44:18 UTC
Or maybe not capsule, as we don't enable ansible on capsules by default?

Comment 5 Evgeni Golov 2020-11-20 10:18:23 UTC
(In reply to Evgeni Golov from comment #4)
> Or maybe not capsule, as we don't enable ansible on capsules by default?

our docs say to enable ansible repo on capsule too, so I went and added the dependency to satellite-common

Comment 6 Brad Buckingham 2021-01-08 20:13:39 UTC
Satellite 6.9 SNAP 8 currently has satellite-6.9.0-0.3.beta.el7sat.noarch.  Based upon the 'fixed in version', aligning to 6.9 and updating status.

Comment 7 Ondrej Gajdusek 2021-02-18 09:05:48 UTC
Verified.
Package satellite-common now requires ansible being installed. This has an effect on Satellite as well as Satellite capsules.

$ rpm -qR satellite-common
ansible < 2.10
ansible >= 2.9

Comment 10 errata-xmlrpc 2021-04-21 13:18:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Moderate: Satellite 6.9 Release), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2021:1313


Note You need to log in before you can comment on or make changes to this bug.