Description of problem:
None of the base Satelite/Capsule packages strictly requires ansible-2.9. Documentation tells customer to enable rhel-7-server-ansible-2.9-rpms repository
thus I assume that this is a strict requirement. If customers do not enable this repository, they will end up with ansible-184.108.40.206-2.el7.noarch.rpm installed from the Satellite Maintenance repository not with ansible-2.9.
Version-Release number of selected component (if applicable):
Steps to Reproduce:
1.rpm -q --whatrequires ansible | grep el7sat | xargs rpm -qR | sort -u | grep ansible
No package requires ansible-2.9 to be installed.
There should be some package that would force installing ansible-2.9.
The reproducer is not quite accurate.
The package that should set the requirement for the ansible package is: tfm-rubygem-smart_proxy_ansible.
$ rpm -qR tfm-rubygem-smart_proxy_ansible | grep ^ansible
Actual: ansible >= 2.2
Expected: ansible >= 2.9
Notes from the triage session:
* the 2.9 requirement is Red Hat support/QE only (we only support that version of ansible in 6.8, the underlying code is probably working with other versions fine)
* >= 2.9 would include 2.10, which we don't support either
* proposal to add a "Requires: ansible >= 2.9, Requires: ansible < 2.10" to the satellite and satellite-capsule RPMs Red Hat ships.
Or maybe not capsule, as we don't enable ansible on capsules by default?
(In reply to Evgeni Golov from comment #4)
> Or maybe not capsule, as we don't enable ansible on capsules by default?
our docs say to enable ansible repo on capsule too, so I went and added the dependency to satellite-common
Satellite 6.9 SNAP 8 currently has satellite-6.9.0-0.3.beta.el7sat.noarch. Based upon the 'fixed in version', aligning to 6.9 and updating status.
Package satellite-common now requires ansible being installed. This has an effect on Satellite as well as Satellite capsules.
$ rpm -qR satellite-common
ansible < 2.10
ansible >= 2.9
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.
For information on the advisory (Moderate: Satellite 6.9 Release), and where to find the updated
files, follow the link below.
If the solution does not work for you, open a new bug report.