Bug 1897

Summary: Wrong keyboard after upgrade
Product: [Retired] Red Hat Linux Reporter: Jukka Lahtinen <walker>
Component: distributionAssignee: Cristian Gafton <gafton>
Status: CLOSED NOTABUG QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 6.0CC: msw
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-03-31 20:42:13 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jukka Lahtinen 1999-03-31 05:10:53 UTC
I did an upgrade from 5.8 to 5.9.
When the upgrade was completed and I booted, the Finnish
keyboard didn't work right.
I finally found out that the symlink from
/etc/rc.d/init.d/keytable to /etc/rc3.d/init.d/S75keytable
had been removed during the upgrade.
Also, /usr/lib/kbd/keymaps/i386/qwerty/fi-latin1.map was
gzipped.
And I also had to define the full path to it in
/etc/sysconfig/keyboard, though it wasn't needed with 5.8.
After these three fixes the keyboard finally worked properly
again.
I suppose the path became necessary again when the keymap
was moved from /usr/lib/kbd/keytables to another directory.
I am quite sure I *did* choose fi-latin1 for keyboard in the
beginning of the upgrade..

Comment 1 Erik Troan 1999-03-31 20:42:59 UTC
This was a 5.8 -> 5.9 artifact, and shouldn't affect users moving
from 5.2 to 6.0